附加1 两个有序链表序列的合并 (20 分)

附加1 两个有序链表序列的合并 (20 分)
已知两个非降序链表序列S1与S2,设计函数构造出S1与S2合并后的新的非降序链表S3。

输入格式:
输入分两行,分别在每行给出由若干个正整数构成的非降序序列,用−1表示序列的结尾(−1不属于这个序列)。数字用空格间隔。

输出格式:
在一行中输出合并后新的非降序链表,数字间用空格分开,结尾不能有多余空格;若新链表为空,输出NULL。

输入样例:

1 3 5 -1
2 4 6 8 10 -1
结尾无空行

输出样例:

1 2 3 4 5 6 8 10
结尾无空行

思路:

两链表都是递增序列,在循环里面一个个比较,新建一个链表用来储存比较的结果数据

代码:

#include <stdio.h>
#include <stdlib.h>
struct node{
    int data;
    struct node *next;
};
struct node *MakeList(){
    struct node *head, *p, *tail;
    head = (struct node*) malloc(sizeof(struct node));
    tail = head;
    while (1){
        p = (struct node*) malloc(sizeof(struct node));
        scanf("%d", &p->data);
        if(p->data == -1) break;
        tail->next = p;
        tail = p;
    }
    tail->next = NULL;
    return head->next;
}

struct node *Combine(struct node *p1, struct node *p2){
    struct node *head, *p, *tail;
    head = (struct node*) malloc(sizeof(struct node));
    tail = head;
    tail->next = NULL;

    while (p1 && p2){
        p = (struct node*) malloc(sizeof(struct node));
        if(p1->data <= p2->data){
            p->data = p1->data;
            p1 = p1->next;
        }else{
            p->data = p2->data;
            p2 = p2->next;
        }
        tail->next = p;
        tail = p;
    }
    if(p2) p1 = p2;
    tail->next = p1;

    return head;
}

void PrintN(struct node *p){
    if(p->next == NULL){
        printf("NULL");
    } else{
        p = p->next;
        while (p){
            if(p->next == NULL) printf("%d", p->data);
            else printf("%d ", p->data);
            p = p->next;
        }
    }
}
int main(){
    struct node *p1, *p2, *p;
    p1 = MakeList();
    p2 = MakeList();
    p = Combine(p1, p2);
    PrintN(p);
    return 0;
}
  • 1
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值