1135 Is It A Red-Black Tree (30 分)--PAT甲级(判断红黑树)

There is a kind of balanced binary search tree named red-black tree in the data structure. It has the following 5 properties:

(1) Every node is either red or black.
(2) The root is black.
(3) Every leaf (NULL) is black.
(4) If a node is red, then both its children are black.
(5) For each node, all simple paths from the node to descendant leaves contain the same number of black nodes.
For example, the tree in Figure 1 is a red-black tree, while the ones in Figure 2 and 3 are not.
在这里插入图片描述
For each given binary search tree, you are supposed to tell if it is a legal red-black tree.

Input Specification:
Each input file contains several test cases. The first line gives a positive integer K (≤30) which is the total number of cases. For each case, the first line gives a positive integer N (≤30), the total number of nodes in the binary tree. The second line gives the preorder traversal sequence of the tree. While all the keys in a tree are positive integers, we use negative signs to represent red nodes. All the numbers in a line are separated by a space. The sample input cases correspond to the trees shown in Figure 1, 2 and 3.

Output Specification:
For each test case, print in a line “Yes” if the given tree is a red-black tree, or “No” if not.

Sample Input:
3
9
7 -2 1 5 -4 -11 8 14 -15
9
11 -2 1 -7 5 -4 8 14 -15
8
10 -7 5 -6 8 15 -11 17
结尾无空行
Sample Output:
Yes
No
No
结尾无空行

题目描述:给出一个二叉树,判断其是否是红黑树

步骤:

1. 建树,逐个结点插入
2. 判断a[0]是否小于0
3. 判断是否有一个结点<0情况下,左右结点有一个小于0
4. 判断每条路上的黑结点数量

#include<iostream>
#include<vector>
#include<cmath>
using namespace std;
vector<int> v;
struct node{
    int val;
    node *left, *right;
};
node* build(node* root, int v){
    if(root == NULL){
        root = new node();
        root->val = v;
        root->left = root->right = NULL;
    }else if(abs(v) < abs(root->val))
        root->left = build(root->left, v);
    else
        root->right = build(root->right, v);
    return root;
}
//判断结点 < 0,孩子结点 < 0?
bool judge1(node* root){
	if(root == NULL) return true;
	if(root->val < 0){
		if(root->left != NULL && root->left->val < 0) return false;
		if(root->right != NULL && root->right->val < 0) return false;
	}
	return judge1(root->left) && judge1(root->right);
}

int getNum(node* root){
	if(root == NULL) return 0;
	int l = getNum(root->left);
	int r = getNum(root->right);
	return root->val > 0 ? max(l, r) + 1 : max(l, r); 
}
//判断每条路径的黑结点数 
bool judge2(node* root){
	if(root == NULL) return true;
	int l = getNum(root->left);
	int r = getNum(root->right);
	if(l != r) return false;
	return judge2(root->left) && judge2(root->right);
}
int main(){
    int k, n;
    scanf("%d", &k);
    while(k --){
        scanf("%d", &n);
        v.resize(n);
        node *root = NULL;
        for(int i = 0; i < n; i ++){
            scanf("%d", &v[i]);
            root = build(root, v[i]);
        } 
        if(v[0] < 0 || !judge1(root) || !judge2(root)) puts("No");
        else puts("Yes");
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值