uva 340Master-Mind Hints(map+pair工具的使用)

MasterMind is a game for two players. One of them, Designer, selects a secret code. The other, Breaker,
tries to break it. A code is no more than a row of colored dots. At the beginning of a game, the players
agree upon the length N that a code must have and upon the colors that may occur in a code.
In order to break the code, Breaker makes a number of guesses, each guess itself being a code. After
each guess Designer gives a hint, stating to what extent the guess matches his secret code.
In this problem you will be given a secret code s1 . . . sn and a guess g1 . . . gn, and are to determine
the hint. A hint consists of a pair of numbers determined as follows.
A match is a pair (i, j), 1 ≤ i ≤ n and 1 ≤ j ≤ n, such that si = gj . Match (i, j) is called strong
when i = j, and is called weak otherwise. Two matches (i, j) and (p, q) are called independent when
i = p if and only if j = q. A set of matches is called independent when all of its members are pairwise
independent.
Designer chooses an independent set M of matches for which the total number of matches and the
number of strong matches are both maximal. The hint then consists of the number of strong followed
by the number of weak matches in M. Note that these numbers are uniquely determined by the secret
code and the guess. If the hint turns out to be (n, 0), then the guess is identical to the secret code.
Input
The input will consist of data for a number of games. The input for each game begins with an integer
specifying N (the length of the code). Following these will be the secret code, represented as N integers,
which we will limit to the range 1 to 9. There will then follow an arbitrary number of guesses, each
also represented as N integers, each in the range 1 to 9. Following the last guess in each game will be
N zeroes; these zeroes are not to be considered as a guess.
Following the data for the first game will appear data for the second game (if any) beginning with a
new value for N. The last game in the input will be followed by a single ‘0’ (when a value for N would
normally be specified). The maximum value for N will be 1000.
Output
The output for each game should list the hints that would be generated for each guess, in order, one hint
per line. Each hint should be represented as a pair of integers enclosed in parentheses and separated by
a comma. The entire list of hints for each game should be prefixed by a heading indicating the game
number; games are numbered sequentially starting with 1. Look at the samples below for the exact
format.

Sample Input
4
1 3 5 5
1 1 2 3
4 3 3 5
6 5 5 1
6 1 3 5
1 3 5 5
0 0 0 0
10
1 2 2 2 4 5 6 6 6 9
1 2 3 4 5 6 7 8 9 1
1 1 2 2 3 3 4 4 5 5
1 2 1 3 1 5 1 6 1 9
1 2 2 5 5 5 6 6 6 7
0 0 0 0 0 0 0 0 0 0
0
Sample Output
Game 1:
(1,1)
(2,0)
(1,2)
(1,2)
(4,0)
Game 2:
(2,4)
(3,2)
(5,0)
(7,0)

题目大意

猜数字游戏 请看 百度

思路:

建立一个原数组,一个猜测数组,然后暴力+标记去搜索;
这里的关键不是搜索,而是你如何去标记,因为标记方式的不对,会问题百出。
余下解释会在代码中给出

AC代码:

//#include<bits/stdc++.h>
#include  <map>
#include  <set>
#include  <cmath>
#include  <queue>
#include  <cstdio>
#include  <vector>
#include  <climits>
#include  <cstring>
#include  <cstdlib>
#include  <iostream>
#include  <algorithm>
#define size size()
using namespace std;
typedef long long ll;
typedef unsigned long long ull;
typedef pair<char,int> pr;
const int maxn=2e5+7;
const int base=131;
map<pr,int>vis;
int s[maxn];
int guess[maxn];
int main()
{
    int n;
    int tot=0;
    while(cin>>n)
    {
        if(!n)
            return 0;
        printf("Game %d:\n",++tot);
        for(int i=1; i<=n; i++)
            cin>>s[i];
        while(1)
        {
            int a=0,b=0;
            vis.clear();
            for(int i=1; i<=n; i++){
                cin>>guess[i];
                if(guess[i]==s[i]) {
                //我采用的标记数字的位置
                //如果对应位置数字相同则a++,该位置不能再进行匹配
                    vis[{'s',i}]=1;//s表示s数组
                    vis[{'g',i}]=1;//g表示guess数组
                    a++;
                }
            }
            if(guess[n]==0)
                break;//这里是判断数组输入0000....的时候要break出来
            /*---------接下来是判断位置不同时,有多少相同的数字*/
            for(int i=1; i<=n; i++)
            {
                for(int j=1; j<=n; j++)
                {
                    /*if(i==j) continue;//因为上面判断了i==j的情况,此处可以continue,不加这句话也是对的*/
                    if(guess[j]==s[i]&&!vis[{'s',i}]&&!vis[{'g',j}])
                    {
                        vis[{'s',i}]=1;//同样,匹配成功则标记1,不能再进行匹配
                        vis[{'g',j}]=1;
                        b++;
                    }
                }
            }
            printf("    (%d,%d)\n",a,b);//四个空格哈,这里有点坑
        }
    }
    return 0;
}

终于体会到了map+pair的方便之处(奇巧淫技?)
“工欲善其事,必先利其器”

  • 3
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 7
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 7
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值