航电 OJ 1002 A+B Problem II (大数运算)

A + B Problem II

Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.

Output
For each test case, you should output two lines. The first line is “Case #:”, # means the number of the test case. The second line is the an equation “A + B = Sum”, Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.


Sample Input

1 2

112233445566778899 998877665544332211

Sample Output

3

1111111111111111110

AC代码:

#include<stdio.h>
#include<string.h>
struct bign
{
	int d[1000];
	int len;
	bign(){
		memset(d,0,sizeof(d)); //初始化数组 
		len=0;
	} 
}; //定义数据结构类型 
bign change(char str[])//定义函数,将字符串数组反转 ,逆序存放 
{
	bign a;
	a.len=strlen(str);
	for(int i=0;i<a.len;i++){ 
    	a.d[i]=str[a.len-1-i]-'0'; 
	}
	return a;	
}
bign add(bign a,bign b)
{
	bign c;
	int carry=0;
	for(int i=0;i<a.len||i<b.len;i++)// 遍历次数为较长数组的长度 
	{
		int temp=a.d[i]+b.d[i]+carry;// 将对应位置数相加,还需加上进位数 
		c.d[c.len++]=temp%10;//存入数组的数字不大于9 
		carry=temp/10;//大于9的,除10,向上进位 
	}
	if(carry!=0)//如果遍历完后依然存在需要进位的数(例如999+1=1000 需要进位1),那么还需要在最后一位补上1表示进了位
	{
		c.d[c.len++]=carry;
	}
	return c;
}
void print(bign a)
{
	for(int i=a.len-1;i>=0;i--)
	{
		printf("%d",a.d[i]);
	}
}
int main()
{
	char str1[1000],str2[1000];//把数字存入字符串中 
	scanf("%s%s",str1,str2);
	bign a=change(str1);//用change()函数,将字符串反转逆序存放,实现从低位开始相加 
	bign b=change(str2);
	print(add(a,b));
	return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值