N - Is There A Second Way Left?(最小生成树,kruskal)

Nasa, being the most talented programmer of his time, can’t think things to be so simple. Recently all
his neighbors have decided to connect themselves over a network (actually all of them want to share
a broadband internet connection 😃). But he wants to minimize the total cost of cable required as he
is a bit fastidious about the expenditure of the project. For some unknown reasons, he also wants a
second way left. I mean, he wants to know the second best cost (if there is any which may be same as
the best cost) for the project. I am sure, he is capable of solving the problem. But he is very busy with
his private affairs(?) and he will remain so. So, it is your turn to prove yourself a good programmer.
Take the challenge (if you are brave enough)…
Input
Input starts with an integer t ≤ 1000 which denotes the number of test cases to handle. Then follows
t datasets where every dataset starts with a pair of integers v (1 ≤ v ≤ 100) and e (0 ≤ e ≤ 200). v
denotes the number of neighbors and e denotes the number of allowed direct connections among them.
The following e lines contain the description of the allowed direct connections where each line is of the
form ‘start end cost’, where start and end are the two ends of the connection and cost is the cost for
the connection. All connections are bi-directional and there may be multiple connections between two
ends.
Output
There may be three cases in the output

  1. No way to complete the task,
  2. There is only one way to complete the task,
  3. There are more than one way.
    Output ‘No way’ for the first case, ‘No second way’ for the second case and an integer c for the
    third case where c is the second best cost. Output for a case should start in a new line.
    Sample Input
    4
    5 4
    1 2 5
    3 2 5
    4 2 5
    5 4 5
    5 3
    1 2 5
    3 2 5
    5 4 5
    5 5
    1 2 5
    3 2 5
    4 2 5
    5 4 5
    4 5 6
    1 0
    Sample Output
    Case #1 : No second way
    Case #2 : No way
    Case #3 : 21
    Case #4 : No second way
    题意:
    输出三种结果:
    没有最短路,输出 No way
    只有一条路输出No second way
    有多条路输出次最短路,
    和本专题的o基本相同,把o题的代码改了改,就accept了
#include <cstdio>
#include <cmath>
#include <cstring>
#include <iostream>
#include <algorithm>
using namespace std;
const int N=888;
int MAX=0x3f3f3f3f;
int n,m;
int dist[N],map[N][N];
int biao[N];
int sum[N];
int x[N],y[N];
int mm[N];
int pre[N];
struct node{
	int u,v,w;
}a[N*(N-1)/2];
bool cmp(node a,node b)
{
	return a.w<b.w;
}
int find(int x)
{
	if(pre[x]==x)
	return x;
	else
	return pre[x]=find(pre[x]);
}
int judge(int u,int v)
{
	int fx=find(u);
	int fy=find(v);
	if(fx!=fy)
	{
		pre[fy]=fx;
		return 1;
	}
	return 0;
}
void unit()
{
	for(int i=1;i<=n;i++)
	{
		pre[i]=i;
	}
}
int main()
{
   int t;
   cin>>t;
   int sum=0;;
   while(t--)
   {
   	sum++;
   	cin>>n>>m;
   	if(n==1&&m==0)//特殊情况,单独讨论 
   	cout<<"Case #"<<sum<<" : No second way"<<endl;
   	else
   	{
   			unit();
   	memset(biao,0,sizeof(biao));
   	for(int i=0;i<m;i++)
   	{
   	  cin>>a[i].u>>a[i].v>>a[i].w;
	}
	sort(a,a+m,cmp);
	int ans=0,num=0;
	int flag=0;//标记,用来判断是否能构成完整路径 
	for(int i=0;i<m;i++)
	{
		if(judge(a[i].u,a[i].v))
		{
			ans+=a[i].w;
			num++;
			biao[i]=1;
			if(num==n-1)
			{
				flag=1;//有最小生成树,
				break;
			}
		}
	}
	int minn=ans;
	cout<<"Case #"<<sum<<" : ";
	if(flag==0)
	cout<<"No way"<<endl;
	else
	{
		flag=0;//重新开始标记
		int minnn=MAX;
	for(int i=0;i<m;i++)
	{
		ans=0,num=0;
		if(biao[i]==1)
		{
			unit();
			for(int j=0;j<m;j++)
			{
				if(i==j)
				continue;
		    if(judge(a[j].u,a[j].v))
	    	{
			ans+=a[j].w;
			num++;
			if(num==n-1)
			{
				flag=1;//除最小生成树之外是否还能构成比他小的树
				minnn=min(minnn,ans);//找次小生成树
					break;
			}
	    	}
			}
		}
	}
	if(flag==0)
	cout<<"No second way"<<endl;
	else
	   cout<<minnn<<endl;
	}
	   }
   }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值