线段树 - Balanced Lineup - POJ - 3264

这篇博客介绍了一种使用线段树数据结构来解决寻找给定范围内牛群中最大身高差的问题。线段树模板被用来构建树,并在查询时分别找到指定范围内最矮和最高的牛的高度,然后计算它们之间的差值。这种方法对于处理大量查询非常高效。
摘要由CSDN通过智能技术生成

Description

For the daily milking, Farmer John’s N cows (1 ≤ N ≤ 50,000) always line up in the same order. One day Farmer John decides to organize a game of Ultimate Frisbee with some of the cows. To keep things simple, he will take a contiguous range of cows from the milking lineup to play the game. However, for all the cows to have fun they should not differ too much in height.

Farmer John has made a list of Q (1 ≤ Q ≤ 200,000) potential groups of cows and their heights (1 ≤ height ≤ 1,000,000). For each group, he wants your help to determine the difference in height between the shortest and the tallest cow in the group.

Input

Line 1: Two space-separated integers, N and Q.
Lines 2…N+1: Line i+1 contains a single integer that is the height of cow i
Lines N+2…N+Q+1: Two integers A and B (1 ≤ A ≤ B ≤ N), representing the range of cows from A to B inclusive.

Output

Lines 1…Q: Each line contains a single integer that is a response to a reply and indicates the difference in height between the tallest and shortest cow in the range.

Sample Input

6 3
1
7
3
4
2
5
1 5
4 6
2 2

Sample Output

6
3
0

题目大意:按顺序给出每头牛的身高,给出范围要求该范围内的最大身高差。

思路:线段树模板,建树时用结构体存储范围的最大最小值,查询时分别查询,用最大减去最小即可。

完整代码如下

#include<stdio.h>
#include<algorithm>
using namespace std;
const int inf=INT_MAX;
const int N=50505;
struct p
{
	int mx,mn;
}tree[N*4];
int n,arr[N];
void build(int id,int start,int end)
{
	if(start==end)
	{
		tree[id].mn=arr[end];
		tree[id].mx=arr[end];
	}
	else
	{
		int mid=(start+end)/2;
		build(id*2,start,mid);
		build(id*2+1,mid+1,end);
		tree[id].mn=min(tree[id*2].mn,tree[id*2+1].mn);
		tree[id].mx=max(tree[id*2].mx,tree[id*2+1].mx);
	}
}
int query_mn(int id,int start,int end,int l,int r)
{
	int ans=inf,mid=(start+end)/2;
	if(l<=start&&end<=r) return tree[id].mn;
	if(l<=mid) ans=min(ans,query_mn(id*2,start,mid,l,r));
	if(mid<r) ans=min(ans,query_mn(id*2+1,mid+1,end,l,r));
	return ans;
}
int query_mx(int id,int start,int end,int l,int r)
{
	int ans=0,mid=(start+end)/2;
	if(l<=start&&end<=r) return tree[id].mx;
	if(l<=mid) ans=max(ans,query_mx(id*2,start,mid,l,r));
	if(mid<r) ans=max(ans,query_mx(id*2+1,mid+1,end,l,r));
	return ans;
}
int main()
{
	int i,m,mx,l,r;
	scanf("%d %d",&n,&m);
	for(i=1;i<=n;i++)
		scanf("%d",&arr[i]);
	build(1,1,n);
	while(m--)
	{
		scanf("%d %d",&l,&r);
		mx=query_mx(1,1,n,l,r)-query_mn(1,1,n,l,r);
		printf("%d\n",mx);
	}
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值