第二周--贪心题解(G)

题G:

The famous ACM (Advanced Computer Maker) Company has rented a floor of a building whose shape is in the following figure.

The floor has 200 rooms each on the north side and south side along the corridor. Recently the Company made a plan to reform its system. The reform includes moving a lot of tables between rooms. Because the corridor is narrow and all the tables are big, only one table can pass through the corridor. Some plan is needed to make the moving efficient. The manager figured out the following plan: Moving a table from a room to another room can be done within 10 minutes. When moving a table from room i to room j, the part of the corridor between the front of room i and the front of room j is used. So, during each 10 minutes, several moving between two rooms not sharing the same part of the corridor will be done simultaneously. To make it clear the manager illustrated the possible cases and impossible cases of simultaneous moving.

For each room, at most one table will be either moved in or moved out. Now, the manager seeks out a method to minimize the time to move all the tables. Your job is to write a program to solve the manager’s problem.
Input
The input consists of T test cases. The number of test cases ) (T is given in the first line of the input. Each test case begins with a line containing an integer N , 1<=N<=200 , that represents the number of tables to move. Each of the following N lines contains two positive integers s and t, representing that a table is to move from room number s to room number t (each room number appears at most once in the N lines). From the N+3-rd line, the remaining test cases are listed in the same manner as above.
Output
The output should contain the minimum time in minutes to complete the moving, one per line.
Sample Input
3
4
10 20
30 40
50 60
70 80
2
1 3
2 200
3
10 100
20 80
30 50
Sample Output
10
20
30

题意:本题难点之一就是理解题目意思。一共400个房间,两两相对,中间有一条走廊,要移动房间里的桌子,每次移动花费10分钟。移动桌子自然要占据走廊空间,如果影响到其他桌子移动,只能等一个10分钟。

思路1:一共两个方向。
1从房间这个点出发,便和世界杯看节目的那个题类似,那个题是在一天内看到最多的节目,于是对节目结束时间进行排序,节目的开始和结束时间有固定的大小关系;而本题不存在这样的关系,房间大的也可以移动向房间小的,便需要多用一下swap,统一都是从小房间移动向大房间。然后对接收桌子的房间进行排序。如果下一个需要移动桌子的房间号"<"上一个接受桌子的房间号,则顺延到下一个时间段。
此思路代码运行结果正确,但未能ac,应该还是有情况没考虑到,后期思考后会删改。

#include <iostream>
#include<algorithm>
#include<cmath>
#include<cstring>

using namespace std;
struct room
{
    int x;
    int y;
}a[202];
bool cmp(room a1,room a2)
{
    return a1.y<a2.y;
}

int main()
{
    int t;
    cin>>t;
    while(t--)
    {
        int n;
        cin>>n;
        for(int i=0;i<n;i++)
        {
            cin>>a[i].x>>a[i].y;
            if(a[i].x>a[i].y)
            {
                int temp=a[i].y;
                a[i].x=a[i].y;
                a[i].y=temp;
            }
        }
        sort(a,a+n,cmp);
        int time=10;
        for(int i=1;i<n;i++)
        {
            int j=a[i-1].y;
            if(a[i].x<j)
            {
                time+=10;
            }
        }
        cout<<time<<endl;
    }
    return 0;
}

思路2
从走廊角度出发。仍然需要统一将桌子从小房间移动向大房间,另开一个数组,先假定所以需要移动桌子的房间都可以占据走廊,然后用数组记录被占用最多次的走廊位置。然后对走廊进行遍历,找到最大值,再*10即可。此思路代码可以ac,只是不是我想到的……

#include <iostream>
#include<algorithm>
#include<cmath>
#include<cstring>

using namespace std;
struct room
{
    int x;
    int y;
}a[202];
bool cmp(room a1,room a2)
{
    return a1.y<a2.y;
}

int main()
{
    int t;
    cin>>t;
    while(t--)
    {
        int n;
        cin>>n;
        for(int i=0;i<n;i++)
        {
            cin>>a[i].x>>a[i].y;
            if(a[i].x>a[i].y)
            {
                int temp=a[i].y;
                a[i].x=a[i].y;
                a[i].y=temp;
            }
        }
        sort(a,a+n,cmp);
        int time=10;
        for(int i=1;i<n;i++)
        {
            int j=a[i-1].y;
            if(a[i].x<j)
            {
                time+=10;
            }
        }
        cout<<time<<endl;
    }
    return 0;
}

总结:
1.系统给定的案例通过并不代表能ac,但这种情况是非常常见的。
2.两处解决办法:
一种是换个思路,但这个已有思路也是花费很久才想出来的,大多数人往往也不会认为自己思路有问题,毕竟给出的案例是可以通过的。但是如果思路得当,是绝对能规避掉很多种情况的考虑。
另一种便是去完善自己的思路,要去想很多种特殊情况,想到自己无法通过的且题面上也未给出的案例模型,想不到就无法ac。感觉难度较大。

因此时间成本才是这两种解决办法的决定因素。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值