H - Packets (贪心)

7 篇文章 0 订阅

A factory produces products packed in square packets of the same height h and of the sizes 11, 22, 33, 44, 55, 66. These products are always delivered to customers in the square parcels of the same height h as the products have and of the size 6*6. Because of the expenses it is the interest of the factory as well as of the customer to minimize the number of parcels necessary to deliver the ordered products from the factory to the customer. A good program solving the problem of finding the minimal number of parcels necessary to deliver the given products according to an order would save a lot of money. You are asked to make such a program.

Input
The input file consists of several lines specifying orders. Each line specifies one order. Orders are described by six integers separated by one space representing successively the number of packets of individual size from the smallest size 11 to the biggest size 66. The end of the input file is indicated by the line containing six zeros.

Output
The output file contains one line for each line in the input file. This line contains the minimal number of parcels into which the order from the corresponding line of the input file can be packed. There is no line in the output file corresponding to the last ``null’’ line of the input file.

Sample Input
0 0 4 0 0 1
7 5 1 0 0 0
0 0 0 0 0 0

Sample Output
2
1

题目大意:
有六种规格的物品(1*1,2*2,3*3,4*4,5*5,6*6)放进规格为6*6的盒子中,问至少需要多少个盒子。

解题思路:
六种规格都考虑一遍

6*6的单独需要1个盒子;

5*5的单独需要1个盒子,可以额外装11个1*1的物品

4*4的单独需要1个盒子,可以额外装5个2*2的物品,没有2*2的物品用1*1的代替

3*3每4个需要1个物品,只有3个时可以额外装1个2*2的物品和5个1*1的物品,没有2*2的物品用1*1的代替。只有2个时可以额外装3个2*2的物品和6个1*1的物品,没有2*2的物品用1*1的代替。只有1个时可以额外装5个2*2的物品和7个1*1的物品,没有2*2的物品用1*1的代替。

剩余的2*2每9个占一个盒子,不够用1*1补上

剩余的1*1每36个占一个盒子

按照上面分析模拟即可

完整代码:

#include<iostream>
#include<algorithm>
using namespace std;
int a[7];

void use(int m,int n){	//模拟使用盒子 
	if(m==6){
		a[6]-=n;
	}else if(m==5){
		a[5]-=n;
		use(1,n*11);
	}else if(m==4){
		a[4]-=n;
		use(2,n*5);
	}else if(m==3){
		a[3]-=n;
		if(n%4==1){
			use(2,5);
			use(1,7);
		}else if(n%4==2){
			use(2,3);
			use(1,6);
		}else if(n%4==3){
			use(2,1);
			use(1,5);
		}
	}else if(m==2){
		if(a[2]!=0){
			if(a[2]>=n){
				a[2]-=n;
			}else{
				a[1]-=(n-a[2])*2;
				a[2]=0;
			}
		}else{
			a[1]-=n*2;
		}
	}else if(m==1){
		if(n>=0){
			a[1]-=n;
		}
	}
}

int main(){
	while(1){
		int flag=0;
		for(int i=1;i<=6;i++){
			cin>>a[i];
			if(a[i]){
				flag=1;
			}
		}
		if(flag){
			int ans=0,m=7;
			while(--m){		//计数 
				if(m==6||m==5||m==4){
					ans+=a[m];
				}else if(m==3){
					ans+=a[m]/4+(a[m]%4!=0);
				}else if(m==2){
					ans+=(a[m]/9)+(a[m]%9!=0);
				}else if(m==1){
					if(a[m]>0){
						ans+=a[m]/36+(a[m]%36!=0);
					}
				}
				int b=a[2];
				use(m,a[m]);
				if(m==2){
					if(b%9!=0){
						use(1,(9-b%9)*4);
					}
				}
			}
			cout<<ans<<endl;
		}else{
			break;
		}
	}
} 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

旧林墨烟

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值