solution of POJ:1017.Packet

Description

A factory produces products packed in square packets of the same height h and of the sizes 1*1, 2*2, 3*3, 4*4, 5*5, 6*6. These products are always delivered to customers in the square parcels of the same height h as the products have and of the size 6*6. Because of the expenses it is the interest of the factory as well as of the customer to minimize the number of parcels necessary to deliver the ordered products from the factory to the customer. A good program solving the problem of finding the minimal number of parcels necessary to deliver the given products according to an order would save a lot of money. You are asked to make such a program.

Input

The input file consists of several lines specifying orders. Each line specifies one order. Orders are described by six integers separated by one space representing successively the number of packets of individual size from the smallest size 1*1 to the biggest size 6*6. The end of the input file is indicated by the line containing six zeros.

Output

The output file contains one line for each line in the input file. This line contains the minimal number of parcels into which the order from the corresponding line of the input file can be packed. There is no line in the output file corresponding to the last “null” line of the input file.

Sample Input

0 0 4 0 0 1
7 5 1 0 0 0
0 0 0 0 0 0

Sample Output

2
1


结题思路
题意要求我们确定至少需要多少个箱子,才能保证将所有盒子放入箱子。
要求1:4,5,6大小的箱子无法在箱子里面共存,所以必须每个一箱;
要点2:3大小的箱子也无法跟4,5,6共存,但3可以跟自己共存,没箱放4个;
要点3:2大小的箱子可以跟4和3共存,跟4在一起可以放5个,跟3在一起时需要考虑3的个数(4个3 * 3的需要0个2 * 2,3个3 * 3需要1个2 * 2,2个3 * 3的需要3个2 * 2,1个3 * 3的需要5个2 * 2)
要点4:余下的空间存放1 * 1。

程序步骤
第一步、如果输入全部为0,跳出循环。
第二步、对需要的2 * 2的数量进行判断,如果实际大于需要,将多余的进行装箱。
第三步、对需要的1 * 1的数量进行判断,如果实际大于需要,将多余的进行装箱。


具体程序(AC)如下

#include <iostream>
using namespace std;

int main() {
    // your code goes here
    int a[7];
    int sum;
    int leftNeed2[4] = {0, 5, 3, 1};
    while(1)
    {
        sum = 0;
        for(int i = 1; i < 7; ++i)
        {
            cin>>a[i];
            sum += a[i];
        }
        if(sum == 0)
            break;
        sum = a[6] + a[5] + a[4] + a[3] / 4;
        int need2 = 5 * a[4] + leftNeed2[a[3] % 4];
        if(a[3] % 4)//多余的3 * 3需要另装一箱
            sum++;
        if(need2 <= a[2])
        {
            sum += (a[2] - need2) / 9;
            if((a[2] - need2) % 9) sum++;
        }
        int need1 = sum * 36 - a[2] * 4 - a[3] * 9 - a[4] * 16 - a[5] * 25 - a[6] * 36;
        if(need1 <= a[1])//剩余的空间全部可以用1 * 1来进行填充
        {
            sum += (a[1] - need1) / 36;
            if((a[1] - need1) % 36) sum++;
        }
        cout<< sum<< endl;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值