P - CS Course (前缀和+后缀和)

Little A has come to college and majored in Computer and Science.

Today he has learned bit-operations in Algorithm Lessons, and he got a problem as homework.

Here is the problem:

You are giving n non-negative integers a1,a2,⋯,an, and some queries.

A query only contains a positive integer p, which means you
are asked to answer the result of bit-operations (and, or, xor) of all the integers except ap.
Input
There are no more than 15 test cases.

Each test case begins with two positive integers n and p
in a line, indicate the number of positive integers and the number of queries.

2≤n,q≤105

Then n non-negative integers a1,a2,⋯,an follows in a line, 0≤ai≤109 for each i in range[1,n].

After that there are q positive integers p1,p2,⋯,pqin q lines, 1≤pi≤n for each i in range[1,q].
Output
For each query p, output three non-negative integers indicates the result of bit-operations(and, or, xor) of all non-negative integers except ap in a line.

Sample Input
3 3
1 1 1
1
2
3

Sample Output
1 1 0
1 1 0
1 1 0

题目大意:
给出一系列数和一些查询数的下标,求出去查询数外其它数的&、|、^运算

解题思路:
^运算比较好求,知道a^b^c^a==b^c就容易做了
&和|需要用前缀和和后缀和处理

完整代码:

#include<iostream>
#include<algorithm>
using namespace std;
int main()
{
	int n,m,a1[100010],a2[100010],b1[100010],b2[100010],c[100010];
	while(cin>>n>>m){
		int ox=0;
		a1[0]=a2[n+1]=(1<<31)-1;
		b1[0]=b2[n+1]=0; 
		for(int i=1;i<=n;i++){
			int x;
			cin>>x;
			ox^=x;
			a1[i]=a2[i]=b1[i]=b2[i]=c[i]=x;
		}
		for(int i=1;i<=n;i++){	//前缀和 
			a1[i]&=a1[i-1];
			b1[i]|=b1[i-1];
		}
		for(int i=n;i>=1;i--){	//后缀和 
			a2[i]&=a2[i+1];
			b2[i]|=b2[i+1];
		}
		while(m--){
			int d;
			cin>>d;
			printf("%d %d %d\n",a1[d-1]&a2[d+1],b1[d-1]|b2[d+1],ox^c[d]);
		}
	}
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

旧林墨烟

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值