一、创建拓扑图
二、配置
1)vlan配置
LSW1:
#
interface Ethernet0/0/2
port link-type access
port default vlan 10
#
interface Ethernet0/0/3
port link-type access
port default vlan 20
#
interface GigabitEthernet0/0/1
port link-type trunk
port trunk allow-pass vlan 2 to 4094
#
LSW2:
#
interface Ethernet0/0/3
port link-type access
port default vlan 10
#
interface Ethernet0/0/4
port link-type access
port default vlan 20
#
interface GigabitEthernet0/0/1
port link-type trunk
port trunk allow-pass vlan 2 to 4094
#
interface GigabitEthernet0/0/2
port link-type access
port default vlan 30
#
2)IP地址配置
LSW1:不需要进行封装,因为两端都是trunk模式
#
interface Vlanif10
ip address 10.1.1.254 255.255.255.0
#
interface Vlanif20
ip address 20.1.1.254 255.255.255.0
#
interface Vlanif40
ip address 40.1.1.1 255.255.255.0
#
LSW2:
#
interface Vlanif30
ip address 30.1.1.1 255.255.255.252
#
interface Vlanif40
ip address 40.1.1.2 255.255.255.0
#
R1:
interface GigabitEthernet0/0/0
ip address 200.1.1.1 255.255.255.252
interface GigabitEthernet0/0/2
ip address 30.1.1.2 255.255.255.252
R2:
interface GigabitEthernet0/0/0
ip address 200.1.1.2 255.255.255.252
interface LoopBack0
ip address 201.11.22.5 255.255.255.0
3)路由配置
LSW1:三层交换机(路由功能)除10.1.1.0、20.1.1.0和40.1.1.0网段之外都是非直连网段,它到任何网段的下一跳都是40.1.1.2
ip route-static 0.0.0.0 0.0.0.0 40.1.1.2
LSW2:直连网段为到10.1.1.0网段和20.1.1.0网段的下一跳为40.1.1.1。到右边下一跳为30.1.1.2写一条静态路由。
ip route-static 0.0.0.0 0.0.0.0 30.1.1.2
ip route-static 10.1.1.0 255.255.255.0 40.1.1.1
ip route-static 20.1.1.0 255.255.255.0 40.1.1.1
R1:R1的直连网段为30.1.1.0和200.1.1.0网段,非直连网段为10.1.1.0、20.1.1.0、40.1.1.0、201.11.22.0。到10.1.1.0、20.1.1.0、40.1.1.0网段的下一跳为30.1.1.1.到201.11.22.0网段的下一跳为200.1.1.2.
ip route-static 10.1.1.0 255.255.255.0 30.1.1.1
ip route-static 20.1.1.0 255.255.255.0 30.1.1.1
ip route-static 40.1.1.0 255.255.255.0 30.1.1.1
ip route-static 201.11.22.0 255.255.255.0 200.1.1.2
R2:R2 除200.1.1.0和201.11.22.0网段都是非直连网段。它到任何非直连网段的下一跳都是200.1.1.1.
ip route-static 0.0.0.0 0.0.0.0 200.1.1.1
三、测试连通性
处于不同vlan的PC可以互相访问,PC也可访问其他任意网段。