PTA 天梯赛 L2-004 这是二叉搜索树吗?(C++实现)

问题描述

L2-004 这是二叉搜索树吗? (25 分)

一棵二叉搜索树可被递归地定义为具有下列性质的二叉树:对于任一结点,

  • 其左子树中所有结点的键值小于该结点的键值;
  • 其右子树中所有结点的键值大于等于该结点的键值;
  • 其左右子树都是二叉搜索树。

所谓二叉搜索树的“镜像”,即将所有结点的左右子树对换位置后所得到的树。

给定一个整数键值序列,现请你编写程序,判断这是否是对一棵二叉搜索树或其镜像进行前序遍历的结果。

输入格式:

输入的第一行给出正整数 N(≤1000)。随后一行给出 N 个整数键值,其间以空格分隔。

输出格式:

如果输入序列是对一棵二叉搜索树或其镜像进行前序遍历的结果,则首先在一行中输出 YES ,然后在下一行输出该树后序遍历的结果。数字间有 1 个空格,一行的首尾不得有多余空格。若答案是否,则输出 NO

样例

输入样例 1:

7
8 6 5 7 10 8 11

输出样例 1:

YES
5 7 6 8 11 10 8

输入样例 2:

7
8 10 11 8 6 7 5

输出样例 2:

YES
11 8 10 7 5 6 8

输入样例 3:

7
8 6 8 5 10 9 11

输出样例 3:

NO

代码:

#include<iostream>
#include<vector>
using namespace std;

int *L;
int n;
vector<int> V;

bool judge(int l, int r)
{
    if(l >= r)
        return true;
    int index = l+1;  //第一个大于根的数,为右子树的根

    while(index <= r && L[index] < L[l])
        index++;
    
    for(int i = index;i <= r;i++)
        if(L[l] > L[i])
            return false;

    return judge(l+1, index-1) && judge(index, r);
}

void LRV(int l, int r)
{
    if(l > r)
        return;
    else if(l == r){
        V.push_back(L[l]);
        return;
    }
    int index = l+1;  

    while(index <= r && L[index] < L[l])
        index++;
    LRV(l+1, index-1);    //左子树
    LRV(index, r);        //右子树
    V.push_back(L[l]);    //根
}

bool judge1(int l, int r)
{
    if(l >= r)
        return true;
    int index = l+1;  //第一个小于等于根的数,为右子树的根

    while(index <= r && L[index] >= L[l])
        index++;
    for(int i = index;i <= r;i++)
        if(L[l] <= L[i])
            return false;

    return judge1(l+1, index-1)&&judge1(index, r);
}

void LRV1(int l, int r)
{
    if(l > r)
        return;
    else if(l == r){
        V.push_back(L[l]);
        return;
    }
    int index = l+1;  

    while(index <= r && L[index] >= L[l])
        index++;
    LRV1(l+1, index-1);    //左子树
    LRV1(index, r);        //右子树
    V.push_back(L[l]);     //根
}

int main()
{
    cin>>n;
    L = new int[n];
    for(int i = 0;i < n;i++)
        cin>>L[i];
    if(L[0] > L[1]){
        if(judge(0, n-1)){
            cout<<"YES"<<endl;
            LRV(0, n-1);
            for(auto i = V.begin();i != V.end();i++){
                if(i != V.begin())
                    cout<<" ";
                cout<<*i;
            }
            cout<<endl;
        }
        else
            cout<<"NO"<<endl;
    }
    else{
        if(judge1(0, n-1)){
            cout<<"YES"<<endl;
            LRV1(0, n-1);
            for(auto i = V.begin();i != V.end();i++){
                if(i != V.begin())
                    cout<<" ";
                cout<<*i;
            }
            cout<<endl;
        }
        else
            cout<<"NO"<<endl;
     }
    return 0;
}

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值