7-1 邻接矩阵表示法创建无向图 (20 分)java

采用邻接矩阵表示法创建无向图G ,依次输出各顶点的度。

输入格式:
输入第一行中给出2个整数i(0<i≤10),j(j≥0),分别为图G的顶点数和边数。 输入第二行为顶点的信息,每个顶点只能用一个字符表示。 依次输入j行,每行输入一条边依附的顶点。

输出格式:
依次输出各顶点的度,行末没有最后的空格。

输入样例:

5 7
ABCDE
AB
AD
BC
BE
CD
CE
DE

输出样例:

2 3 3 3 3
import java.util.*;

public class Main {

    public static void main(String[] args) {
        Scanner sc = new Scanner(System.in);
        int n = sc.nextInt();
        int m = sc.nextInt();
        HashMap<Character, Integer> hm = new HashMap<Character, Integer>();
        String spoint = sc.next();
        char[] c = new char[n];
        for (int i = 0; i < spoint.length(); i++) {
            hm.put(spoint.charAt(i), 0);
            c[i] = spoint.charAt(i);
        }
        for (int i = 0; i < m; i++) {
            String temp = sc.next();
            hm.put(temp.charAt(0), hm.get(temp.charAt(0)) + 1);
            hm.put(temp.charAt(1), hm.get(temp.charAt(1)) + 1);
        }
        String sum = "";
        for (char x : c) {
            sum += hm.get(x) + " ";
        }
        System.out.println(sum.substring(0, sum.length() - 1));
    }
}

  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 5
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 5
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值