7-3 生化危机 (20 分)java版

人类正在经历一场生化危机,许多城市已经被病毒侵袭,这些城市中的人们为了避免感染病毒,计划开车逃往其他没有被病毒入侵的城市(安全城市)。有些城市之间有公路直达,有些没有。虽然他们知道哪些城市是安全的,但是不知道有没有一条安全路径能够到达安全城市(只有该路径上经过的所有城市都是安全的,该路径才是安全路径)。请你编写一个程序帮助他们判断。

输入格式:
输入第一行为三个正整数,分别表示所有城市个数m(m<=100)、安全城市个数n(m<=50)、公路个数k(k<=100)。随后一行给出n个安全城市的编号。随后k行,每一行给出两个整数,表示连接一条公路的两个城市编号。最后一行输入两个整数,分别表示当前所在城市s、目标城市d。每行整数之间都用空格分隔。

输出格式:
若目标城市已被病毒入侵(非安全城市),输出"The city i is not safe!";若目标城市为安全城市且从当前所在城市能够经过一条安全路径到达目标城市,输出"The city can arrive safely!";若目标城市为安全城市但是从当前所在城市没有一条安全路径到达目标城市,输出"The city can not arrive safely!",i为目标城市编号。

输入样例1:

5 2 5
3 4
0 1
0 2
0 4
1 2
2 4
0 4

输出样例1:

The city 4 can arrive safely!

输入样例2:

5 2 5
3 4
0 1
0 2
0 4
1 2
2 4
0 3

输出样例2:

The city 3 can not arrive safely!

输入样例3:

5 2 5
3 4
0 1
0 2
0 4
1 2
2 4
0 1

输出样例3:

The city 1 is not safe!
import java.util.*;

public class Main {

    public static void main(String[] args) {
        Scanner sc = new Scanner(System.in);
        int m = sc.nextInt(), n = sc.nextInt(), k = sc.nextInt();
        int[][] city = new int[m][m];
        boolean[] safe_city = new boolean[m];
        for (int i = 0; i < n; i++) {
            safe_city[sc.nextInt()] = true;
        }
        for (int i = 0; i < k; i++) {
            int from = sc.nextInt(), to = sc.nextInt();
            city[from][to] = 1;
            city[to][from] = 1;
        }
        int begin = sc.nextInt(), end = sc.nextInt();
        getpath(begin, end, city, safe_city);
    }

    public static void getpath(int begin, int end, int[][] safe_city, boolean[] city) {
        if (!city[end]) {
            System.out.println("The city " + end + " is not safe!");
            return;
        }
        Stack<Integer> path = new Stack<Integer>();
        int p = begin;
        path.push(p);
        city[p] = false;
        while (true) {
            boolean ispush = false;
            for (int i = 0; i < safe_city[p].length; i++) {
                if (safe_city[p][i] == 1 && city[i]) {
                    path.push(i);
                    ispush = true;
                    city[i] = false;
                    break;
                }
            }
            if (ispush) {
                p = path.peek();
                if (p == end) {
                    System.out.println("The city " + end + " can arrive safely!");
                    return;
                }
            } else {
                if (!path.isEmpty()) {
                    path.pop();
                    if (!path.isEmpty())
                        p = path.peek();
                } else {
                    System.out.println("The city " + end + " can not arrive safely!");
                    return;
                }
            }
        }
    }
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值