HDU1686 Oulipo (KMP模板题)

7 篇文章 0 订阅

Input

The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:

One line with the word W, a string over {'A', 'B', 'C', …, 'Z'}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).
One line with the text T, a string over {'A', 'B', 'C', …, 'Z'}, with |W| ≤ |T| ≤ 1,000,000.

Output

For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.
 

Sample Input

3
BAPC
BAPC
AZA
AZAZAZA
VERDI
AVERDXIVYERDIAN

Sample Output

1
3
0
#include "bits/stdc++.h"
using namespace std;
int p[1000005];
string str,str1;
int getNaxt(){
    memset(p,0, sizeof(p));
    int len=0,i=1;
    while (i<str.size()){
        if(str[len]==str[i]){
            len++;
            p[i]=len;
            i++;
        }else{
            if(len>0){
                len=p[len-1];
            }else{
                p[i]=len;
                i++;
            }
        }
    }
}
int kmp(){
    int i=0,j=0,ans=0;
    while (i<str.size()){
        if(str1[j]==str[i]){
            i++;
            j++;
        }else{
            if(j>0){
                j=p[j-1];
            }else{
                p[i]=j;
                i++;
            }
        }
        if(j==str1.size()){
            ans++;
            j=p[j-1];
        }
    }
    return ans;
}
int main(){
    ios::sync_with_stdio(0);
    int n;
    cin>>n;
    while (n--){
        cin>>str1>>str;
        getNaxt();
        int len=kmp();
        cout<<len<<endl;
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值