HDU 1686 Oulipo KMP入门



Oulipo

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 14846    Accepted Submission(s): 5852


Problem Description
The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter 'e'. He was a member of the Oulipo group. A quote from the book:

Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination, l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…

Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive 'T's is not unusual. And they never use spaces.

So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {'A', 'B', 'C', …, 'Z'} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.

 

Input
The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:

One line with the word W, a string over {'A', 'B', 'C', …, 'Z'}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).
One line with the text T, a string over {'A', 'B', 'C', …, 'Z'}, with |W| ≤ |T| ≤ 1,000,000.
 

Output
For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.

 

Sample Input
      
      
3 BAPC BAPC AZA AZAZAZA VERDI AVERDXIVYERDIAN
 

Sample Output
      
      
1 3 0
 

Source
 

Recommend
lcy   |   We have carefully selected several similar problems for you:   1358  1711  3336  3746  2203 
 


简单的kmp,其实kmp就是那两个函数,找了两个比较好的教程分别是kmp(http://www.cnblogs.com/c-cloud/p/3224788.html),和这个题的讲解(http://acm.split.hdu.edu.cn/showproblem.php?pid=1686


讲解的确实好,初学者 建议 先看第一个,在看第二个

ac代码

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <iostream>
#define ll long long
using namespace std;
const int max_size_1=10010;
const int max_size_2=1000010;
char word[max_size_1];
char text[max_size_2];
int nex[max_size_1];

void initNex(){
	int len=strlen(word);
	nex[0]=-1;
	for(int j=1;j<len;j++){
		int i=nex[j-1];
		while( (i >=0 ) && ( word[i+1] != word[j] ) ){
			i=nex[i];
		}
		if(word[i+1]==word[j]){
			nex[j]=i+1;
		}
		else
			nex[j]=-1;
	}
}

int solve(){
	int cnt=0;
	int i=0;
	int j=0;
	int lenp=strlen(word);
	int lens=strlen(text);
	
	while(i <= lens){
		if(i==lens){
			if(j==lenp)
				cnt++;
			
			break ;
		}
		if(text[i] == word[j]){
			i++;
			j++;
		}
		else{
			if(j==0)
				i++;
			else
				j=nex[j-1]+1;
		}
		if(j >= lenp){
			cnt++;
			j=nex[lenp-1]+1;
		}
	}
	
	return cnt;
}

int main(){
	
	int t;
	
	scanf("%d",&t);
	
	while(t--){
		memset(word,0,sizeof(word));
		memset(text,0,sizeof(text));
		memset(nex,0,sizeof(nex));
		
		scanf("%s",word);
		scanf("%s",text);
		initNex();
		int ans=0;
		
		ans=solve();
		printf("%d\n",ans);
	}
		
	
	return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值