【PAT A1022】Digital Library

文章描述了一个数字图书馆的模型,其中包含数百万本图书,按标题、作者、关键词等组织。给定查询,系统需返回匹配书籍的ID,排序升序。解决方案是使用多个映射数据结构来存储信息,并根据查询类型进行查找。示例代码展示了如何用C++实现这一功能。
摘要由CSDN通过智能技术生成

题目

A Digital Library contains millions of books, stored according to their titles, authors, key words of their abstracts, publishers, and published years. Each book is assigned an unique 7-digit number as its ID. Given any query from a reader, you are supposed to output the resulting books, sorted in increasing order of their ID’s.

Input Specification:
Each input file contains one test case. For each case, the first line contains a positive integer N (≤10
4
) which is the total number of books. Then N blocks follow, each contains the information of a book in 6 lines:

  • Line #1: the 7-digit ID number;
  • Line #2: the book title – a string of no more than 80 characters;
  • Line #3: the author – a string of no more than 80 characters;
  • Line #4: the key words – each word is a string of no more than 10
    characters without any white space, and the keywords are separated by
    exactly one space;
  • Line #5: the publisher – a string of no more than 80 characters;
  • Line #6: the published year – a 4-digit number which is in the range
    [1000, 3000].

It is assumed that each book belongs to one author only, and contains no more than 5 key words; there are no more than 1000 distinct key words in total; and there are no more than 1000 distinct publishers.

After the book information, there is a line containing a positive integer M (≤1000) which is the number of user’s search queries. Then M lines follow, each in one of the formats shown below:

  • 1: a book title
  • 2: name of an author
  • 3: a key word
  • 4: name of a publisher
  • 5: a 4-digit number representing the year

Output Specification:
For each query, first print the original query in a line, then output the resulting book ID’s in increasing order, each occupying a line. If no book is found, print Not Found instead.

Sample Input:
3
1111111
The Testing Book
Yue Chen
test code debug sort keywords
ZUCS Print
2011
3333333
Another Testing Book
Yue Chen
test code sort keywords
ZUCS Print2
2012
2222222
The Testing Book
CYLL
keywords debug book
ZUCS Print2
2011
6
1: The Testing Book
2: Yue Chen
3: keywords
4: ZUCS Print
5: 2011
3: blablabla

Sample Output:
1: The Testing Book
1111111
2222222
2: Yue Chen
1111111
3333333
3: keywords
1111111
2222222
3333333
4: ZUCS Print
1111111
5: 2011
1111111
2222222
3: blablabla
Not Found

题意

给出N本书的编号、书名、作者、关键词、出版社及出版年份,然后进行M个查询,根据查询的信息给出所有书的编号。

解答

建立多个map<string,set>容器,存储符合对应信息的图书编号,然后根据提供的查询信息及数字,到对应的map容器中查询即可。

代码如下:

#include <cstdio>
#include <map>
#include <set>
#include <iostream>
#include <string>
using namespace std;

void query(map<string,set<int> > &mp, string &str){
    set<int>::iterator it;
    if(mp[str].size() == 0) printf("Not Found\n");
    else{
        for(it=mp[str].begin();it!=mp[str].end();it++){
            printf("%07d\n",*it);
        }
    }
}
int main(){
    int n,m,id,fm;
    char c;
    map<string,set<int> > mptitle,mpauthor,mpkey,mppublisher,mpyear;
    string title,author,key,publisher,year;
    scanf("%d",&n);
    while(n--){
        scanf("%d",&id);
        getchar();
        getline(cin,title);
        mptitle[title].insert(id);
        getline(cin,author);
        mpauthor[author].insert(id);
        while(cin >> key){
            mpkey[key].insert(id);
            c = getchar();
            if(c == '\n') break;
        }
        getline(cin,publisher);
        mppublisher[publisher].insert(id);
        getline(cin,year);
        mpyear[year].insert(id);
    }
    string str;
    scanf("%d",&m);
    while(m--){
        scanf("%d: ",&fm);
        getline(cin,str);
        printf("%d: %s\n",fm,str.c_str());
        if(fm == 1){
            query(mptitle,str);
        }
        else if(fm == 2){
            query(mpauthor,str);
        }
        else if(fm == 3){
            query(mpkey,str);
        }
        else if(fm == 4){
            query(mppublisher,str);
        }
        else if(fm == 5){
            query(mpyear,str);
        }
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值