二分图(最大匹配)

1.引入库

代码如下(示例):

Farmer John completed his new barn just last week, complete with all the latest milking technology. Unfortunately, due to engineering problems, all the stalls in the new barn are different. For the first week, Farmer John randomly assigned cows to stalls, but it quickly became clear that any given cow was only willing to produce milk in certain stalls. For the last week, Farmer John has been collecting data on which cows are willing to produce milk in which stalls. A stall may be only assigned to one cow, and, of course, a cow may be only assigned to one stall. 
Given the preferences of the cows, compute the maximum number of milk-producing assignments of cows to stalls that is possible. 
Input
The input includes several cases. For each case, the first line contains two integers, N (0 <= N <= 200) and M (0 <= M <= 200). N is the number of cows that Farmer John has and M is the number of stalls in the new barn. Each of the following N lines corresponds to a single cow. The first integer (Si) on the line is the number of stalls that the cow is willing to produce milk in (0 <= Si <= M). The subsequent Si integers on that line are the stalls in which that cow is willing to produce milk. The stall numbers will be integers in the range (1..M), and no stall will be listed twice for a given cow.
Output
For each case, output a single line with a single integer, the maximum number of milk-producing stall assignments that can be made.
题目大意:有n头牛,m个牲口棚,一个牛只能住一个牲口棚,一个牲口棚也只能住一头牛。每头牛只接受住其中一些牲口棚,在输入中给出,然后问你最多能够安排多少头牛。

Sample Input
5 5
2 2 5
3 2 3 4
2 1 5
3 1 2 5
1 2 
Sample Output
4
2.读入数据

代码如下(示例):

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int n1,n2,k;
int map[1001][1001],vis[1001],book[1001];
int find(int x)
{
    int i;
    for(i=1;i<=n2;i++)
    {
        if(map[x][i]&&!vis[i])				//该点存在且未被访问过 
        {
            vis[i]=1;
            if(book[i]==0||find(book[i]))  //如果点I未被配对或者找到了新的配对 --------@1 
			{
                book[i]=x;					//更新配对关系 
                return 1;
            }
        }
    }
    return 0;
}
int main()
{
    while( scanf("%d%d",&n1,&n2)!=EOF)
	{
        memset(map,0,sizeof map);			// !!!
        memset(book,0,sizeof book);			//!!!
        for(int j=1;j<=n1;j++)
    {
        scanf("%d",&k);
        for(int i=0;i<k;i++)
    	{
        int y;
        scanf("%d",&y);
        map[j][y]=1;
    	}
	}
    int s=0;
    for(int i=1;i<=n1;i++)				//对所有的点一一尝试完毕知道找不到增广路为止 
    {
        memset(vis,0,sizeof(vis));			//!!!一定要清空上次搜索时的标记 
        if(find(i)) s++;				//该点能找到对应的配对关系 
    }
    printf("%d\n",s);
}
    return 0;
     
}

总结:

@1:!!显然前者较为简单直接找到了配对的对象
		后者则没有第一时间找到配对关系需要向前递推 这里我采用了递归 
本题为二分图最大匹配问题!!注意点的标记

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

风遥~

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值