优先队列

1.引入库

A group of cows grabbed a truck and ventured on an expedition deep into the jungle. Being rather poor drivers, the cows unfortunately managed to run over a rock and puncture the truck's fuel tank. The truck now leaks one unit of fuel every unit of distance it travels. 

To repair the truck, the cows need to drive to the nearest town (no more than 1,000,000 units distant) down a long, winding road. On this road, between the town and the current location of the truck, there are N (1 <= N <= 10,000) fuel stops where the cows can stop to acquire additional fuel (1..100 units at each stop). 

The jungle is a dangerous place for humans and is especially dangerous for cows. Therefore, the cows want to make the minimum possible number of stops for fuel on the way to the town. Fortunately, the capacity of the fuel tank on their truck is so large that there is effectively no limit to the amount of fuel it can hold. The truck is currently L units away from the town and has P units of fuel (1 <= P <= 1,000,000). 

Determine the minimum number of stops needed to reach the town, or if the cows cannot reach the town at all. 

Input

* Line 1: A single integer, N 

* Lines 2..N+1: Each line contains two space-separated integers describing a fuel stop: The first integer is the distance from the town to the stop; the second is the amount of fuel available at that stop. 

* Line N+2: Two space-separated integers, L and P

Output

* Line 1: A single integer giving the minimum number of fuel stops necessary to reach the town. If it is not possible to reach the town, output -1.

 题目大意:一辆车从初点到终点至少需要在几个站停下加油;

分析:显然只有当油消耗完时再加油且加当下能够加的最多的油走完所有的路程才能满足停车次数最少

代码如下(示例):

Input
* Line 1: A single integer, N 

* Lines 2..N+1: Each line contains two space-separated integers describing a fuel stop: The first integer is the distance from the town to the stop; the second is the amount of fuel available at that stop. 

* Line N+2: Two space-separated integers, L and P
Output
* Line 1: A single integer giving the minimum number of fuel stops necessary to reach the town. If it is not possible to reach the town, output -1.

2.读入数据

Sample Input
4
4 4
5 2
11 5
15 10
25 10
Sample Output
2

代码如下(示例):

#include<stdio.h>
#include<queue>
#include<algorithm>
using namespace std;
struct k
{
    int dis,oil;
}a[100010];
bool comp(k a,k b)
{
    return a.dis>b.dis;
}
priority_queue<int> q;   //为了将可加油多的预存值先拿出来 
int main()
{ 
    int n,l,w,ans=0,i;
    scanf("%d",&n);
    a[n+1].dis=0,a[n+1].oil=0;
    for(i=1;i<=n;++i)
    {
    	scanf("%d%d",&a[i].dis,&a[i].oil);
	}
    scanf("%d%d",&l,&w);
    a[0].dis=l;
    sort(a+1,a+1+n,comp);	//按照距离终点由远及近的顺序排列	
    for(i=1;i<=n+1;++i)
    {
        if(w>=a[i-1].dis-a[i].dis)		//此时的油可以使车达到下一目的地 
		{
            w-=a[i-1].dis-a[i].dis;   //油箱内剩余的油量 
            q.push(a[i].oil);		//将经过该点可加的但没加的油记录下来 
		}
        else
        {
            a[i-1].dis-=w;		//距离下一站还需要多少距离(即还需要多少油) 
            w=0;				//此时油箱内已经没有油了 
            if(q.empty())		//如果队列没有预存的油则不能达到目的地 
                break;
            w+=q.top();	//如果有预存的油全部加给卡车 
			i--;				 
            q.pop();	//此时队列预存少一 
            ans++;		//需要加油的次数 
        }
    }
    if(i==n+2)		 
        printf("%d\n",ans);
    else
        printf("-1\n");
    return 0;
}


总结:

本题考察了优先队列,需要特别注意范围问题,第二点:当没有到达下一目的地而油又不够了!!但此时你已经i++;故需要i--;

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

风遥~

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值