多重背包问题转换为01背包问题(二进制优化)

1.引入库

A Bank plans to install a machine for cash withdrawal. The machine is able to deliver appropriate @ bills for a requested cash amount. The machine uses exactly N distinct bill denominations, say Dk, k=1,N, and for each denomination Dk the machine has a supply of nk bills. For example, 

N=3, n1=10, D1=100, n2=4, D2=50, n3=5, D3=10 

means the machine has a supply of 10 bills of @100 each, 4 bills of @50 each, and 5 bills of @10 each. 

Call cash the requested amount of cash the machine should deliver and write a program that computes the maximum amount of cash less than or equal to cash that can be effectively delivered according to the available bill supply of the machine. 

Notes: 
@ is the symbol of the currency delivered by the machine. For instance, @ may stand for dollar, euro, pound etc. 

Input

The program input is from standard input. Each data set in the input stands for a particular transaction and has the format: 

cash N n1 D1 n2 D2 ... nN DN 

where 0 <= cash <= 100000 is the amount of cash requested, 0 <=N <= 10 is the number of bill denominations and 0 <= nk <= 1000 is the number of available bills for the Dk denomination, 1 <= Dk <= 1000, k=1,N. White spaces can occur freely between the numbers in the input. The input data are correct. 

Output

For each set of data the program prints the result to the standard output on a separate line as shown in the examples below. 

题目大意:到银行换钱,问在所需要的数额内,最多能换多少钱。

因为每个面值的钱数都是有数的,但非1,故该问题为多重背包问题,但因为每张面值得之都不知道,当这个数为1000时无疑是很糟糕的,因此这里采用二进制优化(即任何一个数都可以用2^k(k=0,1,2....)加和的方式表示出来,如果将张数拆分并乘以面值则可得到新的面值,将这些新的面值一一存起,就可以转换为01背包问题。

2.读入数据

Sample Input

735 3  4 125  6 5  3 350
633 4  500 30  6 100  1 5  0 1
735 0
0 3  10 100  10 50  10 10

Sample Output

735
630
0
0

3.代码如下:

#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<iostream>
using namespace std;
const int maxn=1e5+10;
int dp[maxn];
int v[maxn];
int main()
{
	int m;
	while(~scanf("%d",&m))
	{
		memset(v,0,sizeof(v));
		int n,cnt=1;
		scanf("%d",&n);
		for(int i=0;i<n;i++)
		{
			int num,t;
			scanf("%d%d",&num,&t);
			int j=1;			//二进制优化起始j唯一 
			while(num>=j)		//优化的数要小于等于总数 
			{
				v[cnt++]=j*t;	// 张数乘于面值 
				num-=j;			//每次都要减去张数,毕竟总数要相等 
				j*=2;			
			}
			v[cnt++]=num*t;   		//别忘了可能有剩余 
		}
		memset(dp,0,sizeof(dp));
		for(int i=1;i<cnt;i++)    //转换成0 1背包问题 
		{
			for(int j=m;j>=v[i];j--)
			{
				dp[j]=max(dp[j],dp[j-v[i]]+v[i]);
			}
		}
		printf("%d\n",dp[m]); 
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

风遥~

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值