D - Friend-Graph

It is well known that small groups are not conducive of the development of a team. Therefore, there shouldn’t be any small groups in a good team.
In a team with n members,if there are three or more members are not friends with each other or there are three or more members who are friends with each other. The team meeting the above conditions can be called a bad team.Otherwise,the team is a good team.
A company is going to make an assessment of each team in this company. We have known the team with n members and all the friend relationship among these n individuals. Please judge whether it is a good team.

Input

The first line of the input gives the number of test cases T; T test cases follow.(T<=15)
The first line od each case should contain one integers n, representing the number of people of the team.(n \leq 3000n≤3000)

Then there are n-1 rows. The iith row should contain n-i numbers, in which number a_{i j}aij​ represents the relationship between member i and member j+i. 0 means these two individuals are not friends. 1 means these two individuals are friends.

Output

Please output ”Great Team!” if this team is a good team, otherwise please output “Bad Team!”.

Sample Input

1
4
1 1 0
0 0
1

Sample Output

Great Team!

题意解析:

需要证明有三个相互都是朋友,或者三个人相互都不是朋友,即输出"Bad Team!",反之输出“Great Team!”

1代表是朋友,0代表不是朋友,例如a[i][j]=1,这说明,第i个人和第i+j个人是朋友,这道题可以直接用暴力判断是否满足条件就可以,但要注意一点,开的数组得是bool类型的,不然会超内存限制。

bool型是二进制类型,只有0和1两个值,一个bool变量,只占一个二进制位,int型是整型占4字节,32个二进制位,是bool的32倍,所以int型会超,bool型不会。

AC代码:

#include<bits/stdc++.h>
using namespace std;
bool a[3010][3010];
int main() {
	int t;
	cin>>t;
	while(t--) {
		memset(a,0,sizeof(a));
		int m;
		cin>>m;
		for(int i=0; i<m; i++) {
			for(int j=i+1; j<m; j++) {
				int num;
				cin>>num;
				a[i][j]=num;
				a[j][i]=num;
				//两个人都要相互认识 
			}
		}
		int f1=0,f2=0;
		for(int i=0; i<m; i++) {
			for(int j=i+1; j<m; j++) {
				for(int k=j+1; k<m; k++) {
					if(a[i][j]&&a[j][k]&&a[i][k]) {
						f1=1;
						break;
					}
					if(a[i][j]==0&&a[i][k]==0&&a[j][k]==0) {
						f2=1;
						break;
					}
				}
			}

		}
		//只需要证明有三个人都是朋友,或者三个人都不是朋友
		if(f1||f2)
			printf("Bad Team!\n");
		else
			printf("Great Team!\n");
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值