Friend-Graph HDU - 6152

It is well known that small groups are not conducive of the development of a team. Therefore, there shouldn’t be any small groups in a good team.
In a team with n members,if there are three or more members are not friends with each other or there are three or more members who are friends with each other. The team meeting the above conditions can be called a bad team.Otherwise,the team is a good team.
A company is going to make an assessment of each team in this company. We have known the team with n members and all the friend relationship among these n individuals. Please judge whether it is a good team.

Input

The first line of the input gives the number of test cases T; T test cases follow.(T<=15)
The first line od each case should contain one integers n, representing the number of people of the team.(n≤3000n≤3000)

Then there are n-1 rows. The iith row should contain n-i numbers, in which number aijaij represents the relationship between member i and member j+i. 0 means these two individuals are not friends. 1 means these two individuals are friends.

Output

Please output ”Great Team!” if this team is a good team, otherwise please output “Bad Team!”.

Sample Input

1
4
1 1 0
0 0
1

Sample Output

Great Team!

首先说一下这个题的意思:即如果有,三个或三个以上的人彼此是朋友或不是朋友的话,这就是个BADTEAM。两种约束条件注意把控。

分析这个题那肯定是暴力求解了,因为他时间够长,据说有一个拉姆齐定理,什么意思呢,主要意思就是一堆人,人数只要超过或等于6个的话,就一定有超过3人互不认识,或为朋友,所以用到这个题中只要是人数大于等于6个的直接是badteam就好了、

1.复杂代码(bool型数组,防超内存)

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<string.h>
#include<queue>
#include<math.h>
#include<vector>
using namespace std;
bool a[3001][3001];
int main()
{
    int n,t;
    //cin >> t;
    scanf("%d", &t);
    while (t--)
    {
        //cin >> n;
        scanf("%d", &n);
        for (int i = 1; i <= n; i++)
        {
            for (int j = i + 1; j <= n; j++)
            {
                //cin >> a[i][j];
                scanf("%d", &a[i][j]);
            }
        }
        int flag = 0;
        for (int i = 1; i <= n; i++)
        {
            for (int j = i + 1; j <= n; j++)
            {
                for (int k = j + 1; k <= n; k++)
                {
                    if (a[i][j] && a[j][k] && a[i][k])
                    {
                        flag = 1; break;
                    }
                    if (!a[i][j] && !a[j][k] && !a[i][k])
                    {
                        flag = 1; break;
                    }
                }
            }
        }
        if (flag)
            //cout << "Bad Team!" << endl;
            printf("Bad Team!\n");
        else
            printf("Great Team!\n");
            //cout << "Great Team!" << endl;
    }
    return 0;
}

2.拉姆齐定理

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<string.h>
#include<queue>
#include<math.h>
#include<vector>
using namespace std;
bool a[15][15];
int main()
{
	int n,t;
	//cin >> t;
	scanf("%d", &t);
	while (t--)
	{
		//cin >> n;
		scanf("%d", &n);
		if (n >= 6)
		{
			for (int i = 1; i <= n; i++)
			{
				for (int j = i + 1; j <= n; j++)
				{
					int x;
					//cin >> a[i][j];
					scanf("%d", &x);
				}
			}
			printf("Bad Team!\n");
		}
		else
		{
			for (int i = 1; i <= n; i++)
			{
				for (int j = i + 1; j <= n; j++)
				{
					//cin >> a[i][j];
					scanf("%d", &a[i][j]);
				}
			}
			int flag = 0;
			for (int i = 1; i <= n; i++)
			{
				for (int j = i + 1; j <= n; j++)
				{
					for (int k = j + 1; k <= n; k++)
					{
						if (a[i][j] && a[j][k] && a[i][k])
						{
							flag = 1; break;
						}
						if (!a[i][j] && !a[j][k] && !a[i][k])
						{
							flag = 1; break;
						}
					}
				}
			}
			if (flag)
				//cout << "Bad Team!" << endl;
				printf("Bad Team!\n");
			else
				printf("Great Team!\n");
		}		//cout << "Great Team!" << endl;
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值