1043 Is It a Binary Search Tree

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the node's key.
  • The right subtree of a node contains only nodes with keys greater than or equal to the node's key.
  • Both the left and right subtrees must also be binary search trees.

If we swap the left and right subtrees of every node, then the resulting tree is called the Mirror Image of a BST.

Now given a sequence of integer keys, you are supposed to tell if it is the preorder traversal sequence of a BST or the mirror image of a BST.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤1000). Then N integer keys are given in the next line. All the numbers in a line are separated by a space.

Output Specification:

For each test case, first print in a line YES if the sequence is the preorder traversal sequence of a BST or the mirror image of a BST, or NO if not. Then if the answer is YES, print in the next line the postorder traversal sequence of that tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input 1:

7
8 6 5 7 10 8 11

Sample Output 1:

YES
5 7 6 8 11 10 8

Sample Input 2:

7
8 10 11 8 6 7 5

Sample Output 2:

YES
11 8 10 7 5 6 8

Sample Input 3:

7
8 6 8 5 10 9 11

Sample Output 3:

NO

保存输入的序列; 

根据输入的结点,首先建立二叉搜索树;

对二叉搜索树进行前序遍历和后序遍历,并分别保存在两个数组中。

可以发现,对于一组二叉搜索树和镜面二叉搜索树:

1)镜面树的先序序列 = reverse(原二叉树的后序序列)

2)镜面树的后序序列 = reverse(原二叉树的先序序列)

由此可得镜面二叉树的先序序列和后序序列,同样分别保存在两个数组中。

将输入的序列与原二叉树和镜面二叉树的先序序列进行对比,如果相同则输出对应的后序序列,否则输出NO。

#include <iostream>
#include <algorithm>
#include <vector>
using namespace std;

vector<int>a;//输入序列
vector<int>pre1;//前序
vector<int>pre2;//镜面前序
vector<int>post1;//后序
vector<int>post2;//镜面后序
struct node {
	int val;
	node *left;
	node *right;
} ;
node *tree = NULL;

node *build(node *root, int x) {
	if (root == NULL) {
		root = new node();
		root->val = x;
		root->left = NULL;
		root->right = NULL;
	} else if (root->val > x) {
		root->left = build(root->left, x);
	} else if (root->val <= x) {
		root->right = build(root->right, x);
	}
	return root;
}

void preOrder(node *root) { //前序遍历
	if (root != NULL) {
		pre1.push_back(root->val);
		preOrder(root->left);
		preOrder(root->right);
	}
}

void postOrder(node *root) { //后序遍历
	if (root != NULL) {
		postOrder(root->left);
		postOrder(root->right);
		post1.push_back(root->val);
	}
}

int main() {
	int n, x;
	cin >> n;
	for (int i = 0; i < n; i++) {
		cin >> x;
		a.push_back(x);
		tree = build(tree, x); //先按搜索二叉树建树
	}
	//前序
	preOrder(tree);
	//后序
	postOrder(tree);
	//镜面前序
	pre2 = post1;
	reverse(pre2.begin(), pre2.end());
	//镜面后序
	post2 = pre1;
	reverse(post2.begin(), post2.end());
	bool flag = 1;
	vector<int>::iterator it1 = a.begin();
	vector<int>::iterator it2 = pre1.begin();
	for (; it1 != a.end(); it1++, it2++) {
		if ((*it1) != (*it2)) {
			flag = 0;
			break;
		}
	}
	if (flag) {
		cout << "YES" << endl;
		it2 = post1.begin();
		int cnt = 1;
		for (; it2 != post1.end(); it2++) {
			cout << *it2;
			if (cnt != n) {
				cout << ' ';
			}
			cnt++;
		}
	} else {
		flag = 1;
		it1 = a.begin();
		it2 = pre2.begin();
		for (; it1 != a.end(); it1++, it2++) {
			if ((*it1) != (*it2)) {
				flag = 0;
				break;
			}
		}
		if (flag) {
			cout << "YES" << endl;
			it2 = post2.begin();
			int cnt = 1;
			for (; it2 != post2.end(); it2++) {
				cout << *it2;
				if (cnt != n) {
					cout << ' ';
				}
				cnt++;
			}
		} else {
			cout << "NO";
		}
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值