1143 Lowest Common Ancestor

The lowest common ancestor (LCA) of two nodes U and V in a tree is the deepest node that has both U and V as descendants.

A binary search tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the node's key.
  • The right subtree of a node contains only nodes with keys greater than or equal to the node's key.
  • Both the left and right subtrees must also be binary search trees.

Given any two nodes in a BST, you are supposed to find their LCA.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers: M (≤ 1,000), the number of pairs of nodes to be tested; and N (≤ 10,000), the number of keys in the BST, respectively. In the second line, N distinct integers are given as the preorder traversal sequence of the BST. Then M lines follow, each contains a pair of integer keys U and V. All the keys are in the range of int.

Output Specification:

For each given pair of U and V, print in a line LCA of U and V is A. if the LCA is found and A is the key. But if A is one of U and V, print X is an ancestor of Y. where X is A and Y is the other node. If U or V is not found in the BST, print in a line ERROR: U is not found. or ERROR: V is not found. or ERROR: U and V are not found..

Sample Input:

6 8
6 3 1 2 5 4 8 7
2 5
8 7
1 9
12 -3
0 8
99 99

Sample Output:

LCA of 2 and 5 is 3.
8 is an ancestor of 7.
ERROR: 9 is not found.
ERROR: 12 and -3 are not found.
ERROR: 0 is not found.
ERROR: 99 and 99 are not found.

自己写的后面三个测试点超时了,好像是递归建树这里超时,在这里记录一下思路:

因为输入的是前序遍历,根据二叉搜索树定义,可以根据前序序列建树,同时记录每个节点的父节点,根节点的父节点为NULL,map记录出现的节点,输入u,v后先判断是否存在,如果都存在则通过r->fa找到父节点,并分别记录从u、v到达根节点的路径,然后将两条路径进行对比,第一个相同的值就是LCA。

#include <iostream>
#include <map>
#include <cstring>
using namespace std;

struct node {
	int val;
	node *fa;
	node *left;
	node *right;
} *nu, *nv;
int n, m, cnt1, cnt2, lca, u, v;
int a[10010], t1[10010], t2[10010];
bool flag1, flag2, find1, find2, flag;
map<int, node *>q;

node *build(node *r, node *fa, int val) {
	if (r == NULL) {
		r = new node();
		r->fa = fa;
		r->left = r->right = NULL;
		r->val = val;
		q[val] = r;
	} else if (val < r->val) {
		r->left = build(r->left, r, val);
	} else {
		r->right = build(r->right, r, val);
	}
	return r;
}

int main() {
	scanf("%d %d", &m, &n);
	node *root = NULL;
	for (int i = 0; i < n; i++) {
		scanf("%d", &a[i]);
		root = build(root, NULL, a[i]);
	}
	while (m--) {
		scanf("%d %d", &u, &v);
		flag = 0;
		flag1 = flag2 = 0;
		find1 = find2 = 0;
		cnt1 = cnt2 = 0;
		map<int, node *>::iterator it1, it2;
		it1 = q.find(u);
		it2 = q.find(v);
		if (q.find(u) != q.end()) {
			flag1 = 1;
		}
		if (q.find(v) != q.end()) {
			flag2 = 1;
		}
		if (!flag1 && !flag2) {
			printf("ERROR: %d and %d are not found.\n", u, v);
		} else if (!flag1 && flag2) {
			printf("ERROR: %d is not found.\n", u);
		} else if (flag1 && !flag2) {
			printf("ERROR: %d is not found.\n", v);
		} else {
			nu = it1->second;
			nv = it2->second;
			while (nu) {
				t1[cnt1++] = nu->val;
				nu = nu->fa;
			}
			while (nv) {
				t2[cnt2++] = nv->val;
				nv = nv->fa;
			}
			for (int i = 0; i < cnt1; i++) {
				if (flag) {
					break;
				}
				for (int j = 0; j < cnt2; j++) {
					if (t1[i] == t2[j]) {
						lca = t1[i];
						flag = 1;
						break;
					}
				}
			}
			if (u == lca) {
				printf("%d is an ancestor of %d.\n", u, v);
			} else if (v == lca) {
				printf("%d is an ancestor of %d.\n", v, u);
			} else {
				printf("LCA of %d and %d is %d.\n", u, v, lca);
			}
		}
	}
	return 0;
}

最后看的柳神的思路,不得不说简直是降维打击,太强了:PAT 1143. Lowest Common Ancestor (30) – 甲级_柳婼的博客-CSDN博客

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值