1154 Vertex Coloring

proper vertex coloring is a labeling of the graph's vertices with colors such that no two vertices sharing the same edge have the same color. A coloring using at most k colors is called a (proper) k-coloring.

Now you are supposed to tell if a given coloring is a proper k-coloring.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers N and M (both no more than 104), being the total numbers of vertices and edges, respectively. Then M lines follow, each describes an edge by giving the indices (from 0 to N−1) of the two ends of the edge.

After the graph, a positive integer K (≤ 100) is given, which is the number of colorings you are supposed to check. Then K lines follow, each contains N colors which are represented by non-negative integers in the range of int. The i-th color is the color of the i-th vertex.

Output Specification:

For each coloring, print in a line k-coloring if it is a proper k-coloring for some positive k, or No if not.

Sample Input:

10 11
8 7
6 8
4 5
8 4
8 1
1 2
1 4
9 8
9 1
1 0
2 4
4
0 1 0 1 4 1 0 1 3 0
0 1 0 1 4 1 0 1 0 0
8 1 0 1 4 1 0 5 3 0
1 2 3 4 5 6 7 8 8 9

Sample Output:

4-coloring
No
6-coloring
No
#include <iostream>
#include <vector>
#include <set>
using namespace std;
int n, m, k, u, v;
int c[10010];
vector<int>g[10010];

int main() {
	cin >> n >> m;
	for (int i = 0; i < m; i++) {
		cin >> u >> v;
		g[u].push_back(v);
		g[v].push_back(u);
	}
	cin >> k;
	while (k--) {
		set<int>s;
		bool flag = 0;
		for (int i = 0; i < n; i++) {
			cin >> c[i];
			s.insert(c[i]);
		}
		for (int i = 0; i < n; i++) {
			for (int j = 0; j < g[i].size(); j++) {
				if (flag) {
					break;
				}
				if (c[i] == c[g[i][j]]) {
					flag = 1;
					break;
				}
			}
		}
		if (flag) {
			cout << "No" << endl;
		} else {
			cout << s.size() << "-coloring" << endl;
		}
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
当然可以,以下是一个简单的回溯法解决图着色问题的代码实现(使用Python语言): ```python # 定义一个函数,用于解决图着色问题 def graph_coloring(graph, colors, vertex): # 如果所有顶点都被着色,则返回True if vertex == len(graph): return True # 逐个尝试当前顶点可以使用的颜色 for color in colors: # 如果当前顶点可以使用该颜色 if is_color_valid(vertex, color, graph): # 将当前顶点着色 graph[vertex]['color'] = color # 递归尝试下一个顶点 if graph_coloring(graph, colors, vertex + 1): return True # 回溯到上一层,尝试下一个颜色 graph[vertex]['color'] = None # 如果无法找到可用颜色,则返回False return False # 定义一个函数,用于检查当前顶点是否可以使用特定颜色 def is_color_valid(vertex, color, graph): for neighbor in graph[vertex]['neighbors']: if graph[neighbor]['color'] == color: return False return True # 示例图:5个顶点,7条边 graph = [ {'neighbors': [1, 2, 3], 'color': None}, {'neighbors': [0, 2], 'color': None}, {'neighbors': [0, 1, 3, 4], 'color': None}, {'neighbors': [0, 2, 4], 'color': None}, {'neighbors': [2, 3], 'color': None} ] # 可用颜色:红、绿、蓝 colors = ['red', 'green', 'blue'] # 调用解决函数,并输出结果 if graph_coloring(graph, colors, 0): for vertex in graph: print('Vertex:', vertex['neighbors'], 'Color:', vertex['color']) else: print('No solution found.') ``` 在上面的代码中,我们使用回溯法来解决图着色问题。主要思路是递归地尝试给每个顶点着色,如果当前顶点无法找到可用的颜色,则回溯到上一层,且尝试下一个颜色,直到找到所有顶点的合法着色方案。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值