暑假第五天HCIP实验

一、题目要求
在这里插入图片描述
二、具体配置


R1
sysname r1                                                               
interface GigabitEthernet0/0/0            
 ip address 16.1.1.1 255.255.255.0                                              
interface GigabitEthernet0/0/1            
 ip address 16.2.1.1 255.255.255.0                                                                                                                              
interface LoopBack0                       
 ip address 1.1.1.1 255.255.255.0         
配置 Tunnel接口                                      
interface Tunnel0/0/0                     
 ip address 10.1.1.1 255.255.255.0        
 tunnel-protocol gre p2mp                 
 source 16.1.1.1                          
 ospf network-type broadcast              
 nhrp entry multicast dynamic             
 nhrp network-id 100                      
                                     
interface Tunnel0/0/1                     
 ip address 20.1.1.1 255.255.255.0        
 tunnel-protocol gre p2mp                 
 source 16.2.1.1                          
 ospf network-type broadcast          //默认为P2P,有三个以上设备会出现的dr选举问题
                                       需要把网络类型改为broadcast,所有的设备都必须改
 nhrp network-id 200                      
 nhrp entry 20.1.1.2 46.1.1.1 register    //向R4,R5注册
 nhrp entry 20.1.1.3 56.1.1.1 register    
配置ospf                                        
ospf 1 router-id 1.1.1.1                  
 area 0.0.0.0                             
  network 1.1.1.1 0.0.0.0                 
  network 10.1.1.0 0.0.0.255              
  network 20.1.1.0 0.0.0.255              
#                                         
ip route-static 0.0.0.0 0.0.0.0 16.1.1.2  
ip route-static 0.0.0.0 0.0.0.0 16.2.1.2  

R2
sysname r2
                                       
interface GigabitEthernet0/0/0            
 ip address 26.1.1.1 255.255.255.0 
       
 interface LoopBack0                       
 ip address 2.2.2.2 255.255.255.0         
配置虚接口                                         
interface Tunnel0/0/0                     
 ip address 10.1.1.2 255.255.255.0        
 tunnel-protocol gre p2mp                 
 source GigabitEthernet0/0/0              
 ospf network-type broadcast              
 ospf dr-priority 0             //优先级为0,表示不参加DR选举          
 nhrp network-id 100       //MGRE 同一网段ID号一样               
 nhrp entry 10.1.1.1 16.1.1.1 register    
                                       
ospf 1 router-id 2.2.2.2                  
 area 0.0.0.0                             
  network 2.2.2.2 0.0.0.0                 
  network 10.1.1.0 0.0.0.255              
                                         
ip route-static 0.0.0.0 0.0.0.0 26.1.1.2

R3
sysname r3                                         
interface GigabitEthernet0/0/0            
 ip address 36.1.1.1 255.255.255.0                                                                                     
interface LoopBack0                       
 ip address 3.3.3.3 255.255.255.0         
                                         
interface Tunnel0/0/0                     
 ip address 10.1.1.3 255.255.255.0        
 tunnel-protocol gre p2mp                 
 source GigabitEthernet0/0/0              
 ospf network-type broadcast              
 ospf dr-priority 0                      
 nhrp network-id 100                      
 nhrp entry 10.1.1.1 16.1.1.1 register    
                                         
ospf 1 router-id 3.3.3.3                  
 area 0.0.0.0                             
  network 3.3.3.3 0.0.0.0                 
  network 10.1.1.0 0.0.0.255              
                                         
ip route-static 0.0.0.0 0.0.0.0 36.1.1.2  

R4
sysname r4                                        
interface GigabitEthernet0/0/0            
 ip address 46.1.1.1 255.255.255.0                                                 
interface LoopBack0                       
 ip address 4.4.4.4 255.255.255.0                                                 
interface Tunnel0/0/1                     
 ip address 20.1.1.2 255.255.255.0 
       
 tunnel-protocol gre p2mp                 
 source 46.1.1.1                          
 ospf network-type broadcast              
 nhrp entry multicast dynamic             
 nhrp network-id 200                      
 nhrp entry 20.1.1.1 16.2.1.1 register    
 nhrp entry 20.1.1.3 56.1.1.1 register    
                                        
ospf 1 router-id 4.4.4.4                  
 area 0.0.0.0                             
  network 4.4.4.4 0.0.0.0                 
  network 20.1.1.0 0.0.0.255              
                                         
ip route-static 0.0.0.0 0.0.0.0 46.1.1.2  

R5
sysname r5                                        
interface GigabitEthernet0/0/0            
 ip address 56.1.1.1 255.255.255.0                                              
interface LoopBack0                       
 ip address 5.5.5.5 255.255.255.0         
                                        
interface Tunnel0/0/0                     
 ip address 20.1.1.3 255.255.255.0        
 tunnel-protocol gre p2mp                 
 source 56.1.1.1                          
 ospf network-type broadcast              
 nhrp entry multicast dynamic             
 nhrp network-id 200                      
 nhrp entry 20.1.1.1 16.2.1.1 register    
 nhrp entry 20.1.1.2 46.1.1.1 register    
                                         
ospf 1 router-id 5.5.5.5                  
 area 0.0.0.0                             
  network 5.5.5.5 0.0.0.0                 
  network 20.1.1.0 0.0.0.255              
                                         
ip route-static 0.0.0.0 0.0.0.0 56.1.1.2  

R6
sysname r6                                                                    
interface GigabitEthernet0/0/0            
 ip address 16.1.1.2 255.255.255.0        
                                        
interface GigabitEthernet0/0/1            
 ip address 26.1.1.2 255.255.255.0        
                                         
interface GigabitEthernet0/0/2            
 ip address 36.1.1.2 255.255.255.0        
                                         
interface GigabitEthernet2/0/0            
 ip address 46.1.1.2 255.255.255.0        
                                         
interface GigabitEthernet3/0/0            
 ip address 56.1.1.2 255.255.255.0        
                                         
interface GigabitEthernet4/0/0            
 ip address 16.2.1.2 255.255.255.0                                                                          
                                         
interface LoopBack0                       
 ip address 6.6.6.6 255.255.255.0
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值