Monthly Expense (POJ - 3273)(整数二分)

Monthly Expense (POJ - 3273)(整数二分)

 

Farmer John is an astounding accounting wizard and has realized he might run out of money to run the farm. He has already calculated and recorded the exact amount of money (1 ≤ moneyi ≤ 10,000) that he will need to spend each day over the next N (1 ≤ N ≤ 100,000) days.

FJ wants to create a budget for a sequential set of exactly M (1 ≤ M ≤ N) fiscal periods called "fajomonths". Each of these fajomonths contains a set of 1 or more consecutive days. Every day is contained in exactly one fajomonth.

FJ's goal is to arrange the fajomonths so as to minimize the expenses of the fajomonth with the highest spending and thus determine his monthly spending limit.

Input

Line 1: Two space-separated integers: N and M
Lines 2..N+1: Line i+1 contains the number of dollars Farmer John spends on the ith day

Output

Line 1: The smallest possible monthly limit Farmer John can afford to live with.

Sample Input

7 5
100
400
300
100
500
101
400

Sample Output

500

Hint

If Farmer John schedules the months so that the first two days are a month, the third and fourth are a month, and the last three are their own months, he spends at most $500 in any month. Any other method of scheduling gives a larger minimum monthly limit.

题目大意:有n个数,然后将n个数分成m组,分成组最大的最小值(就是所分的情况的中的最小值比其他情况的最小值大);

解题思路:很明显L会是所有数的最小值(当N==M时),R为所有数相加(m == 1),然后用cnt记录分成的段数,所有最后的cnt要加1, 因为最后那段划分了但是cnt没有加1。

                  因为取最小的最大值, L能到R的某个位置之前肯定都能分成m组,但不是最优解。因为能够取到mid, 即用L = mid。

AC代码:

#include <iostream>
#include <queue>
#include <map>
using namespace std;

#define ll long long
#define INF 0x3f3f3f3f + 0x3f3f3f3f;

const int MAX = 1e6;
int a[MAX];

int main() {
    int n, m;
    cin >> n >> m;
    int l = -1, r = 0, mid;
    for (int i = 0; i < n; i++) {
        cin >> a[i];
        if (l < a[i]) l = a[i];
        r += a[i];
    }
    while (l < r) {
        mid = (l + r) / 2;
        int cnt = 0;
        int sum = 0;
        for (int i = 0; i < n; i++) {
            if (sum + a[i] > mid) {
                cnt++;
                sum = a[i];
            }else{
                sum += a[i];
            }
        }
        cnt++;
        if (cnt <= m) r = mid;
        else
        {
            l = mid + 1;
        }
        
    }
    cout << r << '\n';
	return 0;
}

 总结:注意划分区域

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值