H - Cleaning Shifts覆盖问题

H - Cleaning Shifts

Farmer John is assigning some of his N (1 <= N <= 25,000) cows to do some cleaning chores around the barn. He always wants to have one cow working on cleaning things up and has divided the day into T shifts (1 <= T <= 1,000,000), the first being shift 1 and the last being shift T.

Each cow is only available at some interval of times during the day for work on cleaning. Any cow that is selected for cleaning duty will work for the entirety of her interval.

Your job is to help Farmer John assign some cows to shifts so that (i) every shift has at least one cow assigned to it, and (ii) as few cows as possible are involved in cleaning. If it is not possible to assign a cow to each shift, print -1.
Input

  • Line 1: Two space-separated integers: N and T

  • Lines 2…N+1: Each line contains the start and end times of the interval during which a cow can work. A cow starts work at the start time and finishes after the end time.
    Output

  • Line 1: The minimum number of cows Farmer John needs to hire or -1 if it is not possible to assign a cow to each shift.

Sample Input
3 10
1 7
3 6
6 10

Sample Output
2
Hint
This problem has huge input data,use scanf() instead of cin to read data to avoid time limit exceed.

INPUT DETAILS:

There are 3 cows and 10 shifts. Cow #1 can work shifts 1…7, cow #2 can work shifts 3…6, and cow #3 can work shifts 6…10.

OUTPUT DETAILS:

By selecting cows #1 and #3, all shifts are covered. There is no way to cover all the shifts using fewer than 2 cows.

题意: 有N头奶牛,工作时间到T,然后给N个奶牛的工作时间段,问最少需要雇佣多少头奶牛。

思路: 肯定是要先排序的,以开始时间递增排序,然后用两层while循环,来找最小的奶牛数量,具体解析请看代码。

#include<stdio.h>
#include<algorithm>
#include<string.h>
using namespace std;
struct stt
{
	int t1;
	int t2;
}a[25500];
bool cmp(stt x,stt y)
{
	if(x.t1==y.t1)
	  return x.t2>y.t2;
	else
	  return x.t1<y.t1;
}
int main()
{
	int i,j,k,tail,head,n,m,f=1;
	scanf("%d %d",&n,&m);
	for(i=0;i<n;i++)
	{
	  scanf("%d %d",&a[i].t1,&a[i].t2);
	}
	
	sort(a,a+n,cmp); 
	if(a[0].t1==1&&a[0].t2>=m)//如果第一个奶牛就可以全部完成。
	{
	  printf("1\n");
	}
	else if(a[0].t1>1)//如果第一头奶牛的开始时间小于1,说明不可能全覆盖。
	{
	  printf("-1\n");
	}
	else
	{
	    tail=head=a[0].t2;
		k=1;i=1;
	//i<n,是小于测试样例个数.
 //tail<m,是不能超出或等于区间的长度,不然就应该跳出循环结束。
 //应为如果大于或等于区间长,说明已经够用了,不用继续找了。	 
		while(i<n&&tail<m)//这里tail与 m不能取等号。 
		{
			
			while(a[i].t1<=tail+1&&i<n)
			{
				if(a[i].t2>head)
				{
				  head=a[i].t2;
				}
				i++;
			}
			if(tail!=head)//不相等说明找到了下一个符合条件的。 
			{
				k++;
				tail=head;
			}
			else//相等,说明有间隔,不能覆盖全部区间,跳出输出“-1”。 
			{
				f=0;
				break;
			}
		}
		//tail<m还要判断,可能所有样例都找完了,还是不等覆盖全部区间。 
		if(tail<m||f==0)
		 printf("-1\n");
		else
		 printf("%d\n",k);
	}
	return 0;
}

对于覆盖的题,有时按开始时间排序比较好,有时按结束时间排序好,要具体分析一下。都是排好序后,从第一个一直往后找,找到符合条件的就找下一个,过程中用一两个字符当成现在的点的状态。

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值