PAT 1021 Deepest Root(深度优先搜索求树高)

A graph which is connected and acyclic can be considered a tree. The height of the tree depends on the selected root. Now you are supposed to find the root that results in a highest tree. Such a root is called the deepest root.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤104) which is the number of nodes, and hence the nodes are numbered from 1 to N. Then N−1 lines follow, each describes an edge by given the two adjacent nodes' numbers.

Output Specification:

For each test case, print each of the deepest roots in a line. If such a root is not unique, print them in increasing order of their numbers. In case that the given graph is not a tree, print Error: K components where K is the number of connected components in the graph.

Sample Input 1:

5
1 2
1 3
1 4
2 5

Sample Output 1:

3
4
5

Sample Input 2:

5
1 3
1 4
2 5
3 4

Sample Output 2:

Error: 2 components

思路:

首先用深度优先遍历求出连通分量的个数,再用深度优先遍历统计每个节点作为根节点时的树高,记录其中最大高度,最后输出以该节点为根的且此时树高为最大深度的节点。

代码如下:

#include<iostream>
#include<vector>
#include<algorithm>
#include<bits/stdc++.h>
#define maxsize 10001
using namespace std;
vector<int>graph[maxsize];
bool visited[maxsize]={false};
int MAX=0;
int deepth[maxsize]={0};
void dfs(int x){
    for(int i=0;i<graph[x].size();i++){
        if(visited[graph[x][i]])    
            continue;
        visited[graph[x][i]]=true;
        dfs(graph[x][i]);
    } 
}
void searchdeepth(int x,int deep,int root){
    if(!visited[x]){
        visited[x]=true;
        for(int i=0;i<graph[x].size();i++){
            if(!visited[graph[x][i]]){
                deepth[root]=max(deepth[root],deep+1);
                MAX=max(MAX,deepth[root]);
                searchdeepth(graph[x][i],deep+1,root);
            }
        }
    }  
}
int main()
{
    int n;
    cin>>n;
    int sum_of_connected=0;
    for(int i=1;i<n;i++){
        int x,y;
        cin>>x>>y;
        graph[x].push_back(y);
        graph[y].push_back(x);
    }
    for(int i=1;i<=n;i++){
        if(!visited[i]){
            dfs(i);
            sum_of_connected++;
        }
    }
    if(sum_of_connected>1)
        cout<<"Error: "<<sum_of_connected<<" components";
    else{
        for(int i=1;i<=n;i++){
            fill(visited,visited+maxsize,false);
            searchdeepth(i,0,i);
        }
        for(int i=1;i<=n;i++)
            if(deepth[i]==MAX)
                cout<<i<<endl;
    }
    return 0;
}

样例结果如下:

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值