Binary Trees(挑战程序设计竞赛题目)

Binary Tree

A binary tree is a tree with a root node in which every node has at most two children.

Your task is to write a program which reads a rooted binary tree T and prints the following information for each node u of T:

node ID of u
parent of u
sibling of u
the number of children of u
depth of u
height of u
node type (root, internal node or leaf)
If two nodes have the same parent, they are siblings. Here, if u and v have the same parent, we say u is a sibling of v (vice versa).

The height of a node in a tree is the number of edges on the longest simple downward path from the node to a leaf.

Here, the given binary tree consists of n nodes and evey node has a unique ID from 0 to n-1.

Input
The first line of the input includes an integer n, the number of nodes of the tree.

In the next n lines, the information of each node is given in the following format:

id left right

id is the node ID, left is ID of the left child and right is ID of the right child. If the node does not have the left (right) child, the left(right) is indicated by -1.

Output
Print the information of each node in the following format:

node id: parent = p, sibling = s, degree = deg, depth = dep, height = h, type

p is ID of its parent. If the node does not have a parent, print -1.

s is ID of its sibling. If the node does not have a sibling, print -1.

deg, dep and h are the number of children, depth and height of the node respectively.

type is a type of nodes represented by a string (root, internal node or leaf. If the root can be considered as a leaf or an internal node, print root.

Please follow the format presented in a sample output below.

Constraints
1 ≤ n ≤ 25
Sample Input 1
9
0 1 4
1 2 3
2 -1 -1
3 -1 -1
4 5 8
5 6 7
6 -1 -1
7 -1 -1
8 -1 -1
Sample Output 1
node 0: parent = -1, sibling = -1, degree = 2, depth = 0, height = 3, root
node 1: parent = 0, sibling = 4, degree = 2, depth = 1, height = 1, internal node
node 2: parent = 1, sibling = 3, degree = 0, depth = 2, height = 0, leaf
node 3: parent = 1, sibling = 2, degree = 0, depth = 2, height = 0, leaf
node 4: parent = 0, sibling = 1, degree = 2, depth = 1, height = 2, internal node
node 5: parent = 4, sibling = 8, degree = 2, depth = 2, height = 1, internal node
node 6: parent = 5, sibling = 7, degree = 0, depth = 3, height = 0, leaf
node 7: parent = 5, sibling = 6, degree = 0, depth = 3, height = 0, leaf
node 8: parent = 4, sibling = 5, degree = 0, depth = 2, height = 0, leaf

Reference
Introduction to Algorithms, Thomas H. Cormen, Charles E. Leiserson, Ronald L. Rivest, and Clifford Stein. The MIT Press.

题意: 给你一个二叉树,让你求出每个点的父亲节点、兄弟节点、子节点数、深度、高度、节点类型(根、内部节点、叶)

求结点的高度

int sethight(int u){
	int h1=0,h2=0;
	if(tree[u].l!=-1)
       h1=sethight(tree[u].l)+1;
	if(tree[u].r!=-1)
	   h2=sethight(tree[u].r)+1;
	return H[u]=( h1 > h2 ? h1 : h2);       
}

求结点的深度

void setdepth(int u,int d){
	if(u==-1) return ;
	D[u]=d;
	setdepth(tree[u].l,d+1);
	setdepth(tree[u].r,d+1);
}

求兄弟节点

int getsibling(int u){
	if(tree[u].fa==-1) return -1;
	if(tree[tree[u].fa].l!=u&&tree[tree[u].fa].l!=-1) return tree[tree[u].fa].l;
	if(tree[tree[u].fa].r!=u&&tree[tree[u].fa].r!=-1) return tree[tree[u].fa].r;
	return -1;
}

下面附上全部代码

#include<bits/stdc++.h>
using namespace std;
const int N=10005;
struct node{
	int fa;
	int l,r;
}tree[N];
int n,D[N],H[N];

void setdepth(int u,int d){
	if(u==-1) return ;
	D[u]=d;
	setdepth(tree[u].l,d+1);
	setdepth(tree[u].r,d+1);
}

int sethight(int u){
	int h1=0,h2=0;
	if(tree[u].l!=-1)
       h1=sethight(tree[u].l)+1;
	if(tree[u].r!=-1)
	   h2=sethight(tree[u].r)+1;
	return H[u]=( h1 > h2 ? h1 : h2);       
}

int getsibling(int u){
	if(tree[u].fa==-1) return -1;
	if(tree[tree[u].fa].l!=u&&tree[tree[u].fa].l!=-1) return tree[tree[u].fa].l;
	if(tree[tree[u].fa].r!=u&&tree[tree[u].fa].r!=-1) return tree[tree[u].fa].r;
	return -1;
}
void print(int u){
	printf("node %d: ",u);
	printf("parent = %d, ",tree[u].fa);
	printf("sibling = %d, ",getsibling(u));
	int deg=0;
	if(tree[u].l!=-1) deg++;
	if(tree[u].r!=-1) deg++;
	printf("degree = %d, ",deg);
	printf("depth = %d, ",D[u]);
	printf("height = %d, ",H[u]);
	if(tree[u].fa==-1){
		printf("root\n");
	} else if(tree[u].l==-1&&tree[u].r==-1){
		printf("leaf\n");
	} else{
		printf("internal node\n");
	}
}

int main(){
	int v,l,r,root=0;
    scanf("%d",&n);
	for(int i=0;i<n;i++) tree[i].fa=-1;
	for(int i=0;i<n;i++){
		scanf("%d %d %d",&v,&l,&r);
		tree[v].l=l;
		tree[v].r=r;
		if(l!=-1) tree[l].fa=v;
		if(r!=-1) tree[r].fa=v;
	}
	for(int i=0;i<n;i++){
		if(tree[i].fa==-1) root=i;
	}
	setdepth(root,0);
	sethight(root);
	for(int i=0;i<n;i++){
		print(i);
	}
	return 0;
}

上面代码是参考了书本,把题目总结了一下,作为笔记记下来。

如果你有任何建议或者批评和补充,请留言指出,不胜感激

  • 3
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值