【PAT(甲级)】1013 Battle Over Cities

It is vitally important to have all the cities connected by highways in a war. If a city is occupied by the enemy, all the highways from/toward that city are closed. We must know immediately if we need to repair any other highways to keep the rest of the cities connected. Given the map of cities which have all the remaining highways marked, you are supposed to tell the number of highways need to be repaired, quickly.

For example, if we have 3 cities and 2 highways connecting city1​-city2​ and city1​-city3​. Then if city1​ is occupied by the enemy, we must have 1 highway repaired, that is the highway city2​-city3​.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 3 numbers N (<1000), M and K, which are the total number of cities, the number of remaining highways, and the number of cities to be checked, respectively. Then M lines follow, each describes a highway by 2 integers, which are the numbers of the cities the highway connects. The cities are numbered from 1 to N. Finally there is a line containing K numbers, which represent the cities we concern.

Output Specification:

For each of the K cities, output in a line the number of highways need to be repaired if that city is lost.

Sample Input:

3 2 3
1 2
1 3
1 2 3

Sample Output:

1
0
0

解题思路:

题目给出城市编号和连通情况,让我们求如果去掉一个城市后,想让接下来的所有城市构成一个连通图所需要添加的街道数量。那么就等于,找到去掉一个城市后,剩下的最大连通分量的数量,连通分量数量减去1就是所要添加的街道数量,所以,构造连通图且求连通分量用dfs算法。

dfs的边界就是删除的城市(因为所有城市到目标删除的城市都不通),或者原城市的v已经访问过。

易错点:

1. 题目中的去掉城市其实是一个思维误导,我们在做题目的时候,其实只要跳过这个城市就行,删除的话,题目就会变得很复杂。

2.在用dfs遍历的时候,记得变量应该从1-N,0-N-1的话会错的,因为城市编号是1-N。

代码:

#include<bits/stdc++.h>
using namespace std;
int N;//城市数量
int M;//街道数量
int K;//待检测的城市数
int city;//存储检测的城市 
vector<int> Graph[100000];//存储连通图 
bool v[100000];//存储是否已经访问过
 
void dfs(int a){//dfs算法 
	if(a==city||v[a]) return;//当找到目标城市,或者已经访问到城市a时就退出 
	v[a]=true;
	for(int i=0;i<(int)Graph[a].size();i++){
		dfs(Graph[a][i]);
	}
}
int main(){
	cin>>N>>M>>K;
	for(int i=0;i<M;i++){
		int j,k;
		cin>>j>>k;
		Graph[j].push_back(k);
		Graph[k].push_back(j);
	}
	for(int i=0;i<K;i++){
		cin>>city;
		memset(v,false,sizeof(v));//对所有访问点置0 
		int sum=0;
		for(int j=1;j<=N;j++){//求出最大连通分量的数量 
			if(j!=city&&!v[j]){
				sum+=1;
				dfs(j);
			}
		}
		cout<<sum-1<<endl;
	}
	return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值