【PAT(甲级)】1047 Student List for Course(超时问题)

Zhejiang University has 40,000 students and provides 2,500 courses. Now given the registered course list of each student, you are supposed to output the student name lists of all the courses.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 numbers: N (≤40,000), the total number of students, and K (≤2,500), the total number of courses. Then N lines follow, each contains a student's name (3 capital English letters plus a one-digit number), a positive number C (≤20) which is the number of courses that this student has registered, and then followed by C course numbers. For the sake of simplicity, the courses are numbered from 1 to K.

Output Specification:

For each test case, print the student name lists of all the courses in increasing order of the course numbers. For each course, first print in one line the course number and the number of registered students, separated by a space. Then output the students' names in alphabetical order. Each name occupies a line.

Sample Input:

10 5
ZOE1 2 4 5
ANN0 3 5 2 1
BOB5 5 3 4 2 1 5
JOE4 1 2
JAY9 4 1 2 5 4
FRA8 3 4 2 5
DON2 2 4 5
AMY7 1 5
KAT3 3 5 4 2
LOR6 4 2 4 1 5

Sample Output:

1 4
ANN0
BOB5
JAY9
LOR6
2 7
ANN0
BOB5
FRA8
JAY9
JOE4
KAT3
LOR6
3 1
BOB5
4 7
BOB5
DON2
FRA8
JAY9
KAT3
LOR6
ZOE1
5 9
AMY7
ANN0
BOB5
DON2
FRA8
JAY9
KAT3
LOR6
ZOE1

解题思路:

给出学生选课信息,按照课程后面跟学生姓名的方式输出。字符串与数字对应的问题,用map。后面存储的记得用vector而不是set,set太耗费时间了。因为要求名字按照字典顺序排列,所以输出的时候要用sort对vector排序一遍。

易错点:

1. 测试点2,对于一门没有学生选的课,我们需要输出此课程编号和0;

2. 超时问题的解决就是,要用vector而不是map,同时输出的时候要用printf而不是cout;

printf输出string类型

string a;
printf("%s",a.c_str());

代码:

#include<bits/stdc++.h>
using namespace std;

int main(){
	int N,K;
	scanf("%d%d",&N,&K);
	map<int,vector<string>> student;//存储课程对应的学生信息 
	for(int i=0;i<N;i++){
		string a;int num;
		cin>>a>>num;
		for(int j=0;j<num;j++){
			int t;
			scanf("%d",&t);
			student[t].push_back(a);
		}
	}
	
	
	for(int i=1;i<=K;i++){
		printf("%d %d\n",i,student[i].size());
		sort(student[i].begin(),student[i].end());//对学生姓名排序 
		for(auto j = student[i].begin();j!=student[i].end();j++){
			string t = *j;
			printf("%s\n",t.c_str());
		}
	}
	
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值