【PAT(甲级)】1052 Linked List Sorting(测试点3,4)

A linked list consists of a series of structures, which are not necessarily adjacent in memory. We assume that each structure contains an integer key and a Next pointer to the next structure. Now given a linked list, you are supposed to sort the structures according to their key values in increasing order.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive N (<105) and an address of the head node, where N is the total number of nodes in memory and the address of a node is a 5-digit positive integer. NULL is represented by −1.

Then N lines follow, each describes a node in the format:

Address Key Next

where Address is the address of the node in memory, Key is an integer in [−105,105], and Next is the address of the next node. It is guaranteed that all the keys are distinct and there is no cycle in the linked list starting from the head node.

Output Specification:

For each test case, the output format is the same as that of the input, where N is the total number of nodes in the list and all the nodes must be sorted order.

Sample Input:

5 00001
11111 100 -1
00001 0 22222
33333 100000 11111
12345 -1 33333
22222 1000 12345

Sample Output:

5 12345
12345 -1 00001
00001 0 11111
11111 100 22222
22222 1000 33333
33333 100000 -1

解题思路:

给出链表,要求我们按照key从小到大的顺序重新排列链表。坑的地方在于,他没说如果给出的链表头是-1或者压根就不存在下面的数据里面的时候要输出“0  -1”(测试点4)。

我们定义两个结构,一个存储数据,一个存储链表的数据。数组的address就是数组的下标,这样就方便找到next对应的数组,并且当重新排列后,就可以直接输出address来输出了。

易错点:

1. 注意超时问题,不能暴力地去查找数组,要用address来代替下标,数组一开始就开大一点;

2. 测试点4,没有对应的链表的时候要输出“0 -1”;(O。o?这居然不说,我还以为输出“0 0”呢,看了别人的才知道,坑死-_-b);

3. 测试点3,要保证首地址的输出也要符合前补0的格式。

代码:

#include<bits/stdc++.h>
using namespace std;

struct lin{
	int address;
	int key=999999999;
	int next=-10;
}L[1000001],L1[1000001];

bool cmp(lin a,lin b){//将key从小到大排序 
	return a.key<b.key;
}

int main(){
	int N;
	int begin;
	cin>>N>>begin;

	for(int i=0;i<N;i++){
		int t;
		cin>>t;
		L[t].address = t;
		cin>>L[t].key>>L[t].next;
	}
	
	if(begin<0||L[begin].next == -10){//测试点4,给出的数据中没有链表的头节点 
		cout<<0<<" -1"<<endl;
		return 0;
	}
	
	int tol = 0;
	for(int i=begin;i!=-1;){
		L1[i] = L[i];
		i = L[i].next;
		tol++;
	}
	
	sort(L1,L1+1000001,cmp);
	printf("%d %05d\n",tol,L1[0].address);//测试点3 
	for(int i=0;i<tol;i++){
		if(i<tol-1){
			printf("%05d %d %05d\n",L1[i].address,L1[i].key,L1[i+1].address);
		}
		else{
			printf("%05d",L1[i].address);
			cout<<" "<<L1[i].key<<" -1"<<endl;
		}
	}
	
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值