People often have a preference among synonyms of the same word. For example, some may prefer "the police", while others may prefer "the cops". Analyzing such patterns can help to narrow down a speaker's identity, which is useful when validating, for example, whether it's still the same person behind an online avatar.
Now given a paragraph of text sampled from someone's speech, can you find the person's most commonly used word?
Input Specification:
Each input file contains one test case. For each case, there is one line of text no more than 1048576 characters in length, terminated by a carriage return \n
. The input contains at least one alphanumerical character, i.e., one character from the set [0-9 A-Z a-z
].
Output Specification:
For each test case, print in one line the most commonly occurring word in the input text, followed by a space and the number of times it has occurred in the input. If there are more than one such words, print the lexicographically smallest one. The word should be printed in all lower case. Here a "word" is defined as a continuous sequence of alphanumerical characters separated by non-alphanumerical characters or the line beginning/end.
Note that words are case insensitive.
Sample Input:
Can1: "Can a can can a can? It can!"
Sample Output:
can 5
解题思路:
题目中给出一个句子,只有[0-9 A-Z a-z
]这些是合法字符,其他的都看成是字母之间的分隔符,要求我们输出其中出现次数最多的单词。
找对应关系,用map<string,int>来存储每个单词出现的次数,然后输出次数最多的单词即可。注意的地方是,单词之间不区别大小写。
易错点:
1. 只有[0-9 A-Z a-z
]这些是合法字符,其他的都堪称是分割符号,例如:aaa**aaaa,就是两个单词分别是aaa和aaaa;
2. 单词之间不区分大小写;
3. 考虑末尾单词没有分割字符直接换行的情况例如输入:
a a a\n 应该输出a 3;
代码:
#include<bits/stdc++.h>
using namespace std;
vector<string> isword(string b){
vector<string> r;
string t;
for(int i=0;i<b.size();i++){
if((b[i]>='0'&&b[i]<='9')||(b[i]>='a'&&b[i]<='z')||(b[i]>='A'&&b[i]<='Z')){
if(b[i]>='A'&&b[i]<='Z'){
t+=b[i]-'A'+'a';
}else{
t+=b[i];
}
}else{
if(t!="")
r.push_back(t);
t = "";
}
}
if(t!="") r.push_back(t);// 测试点4,最后一个word后没有非法字符直接回车
return r;
}
int main(){
string a;
getline(cin,a);
map<string,int> num;
vector<string> r = isword(a);
for(auto t = r.begin();t!=r.end();t++){
num[*t]++;
}
auto j = num.begin();
for(auto i = num.begin();i!=num.end();i++){
if(i->second>j->second){
j = i;
}
}
cout<<j->first<<" "<<j->second;
return 0;
}