poj3061尺取法+队列实现

Subsequence

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 44299Accepted: 17757

Description

A sequence of N positive integers (10 < N < 100 000), each of them less than or equal 10000, and a positive integer S (S < 100 000 000) are given. Write a program to find the minimal length of the subsequence of consecutive elements of the sequence, the sum of which is greater than or equal to S.

Input

The first line is the number of test cases. For each test case the program has to read the numbers N and S, separated by an interval, from the first line. The numbers of the sequence are given in the second line of the test case, separated by intervals. The input will finish with the end of file.

Output

For each the case the program has to print the result on separate line of the output file.if no answer, print 0.

Sample Input

2
10 15
5 1 3 5 10 7 4 9 2 8
5 11
1 2 3 4 5

Sample Output

2
3

Source

Southeastern Europe 2006

即给出了N个正整数(10<N<100 000)的序列,每个正整数小于或等于10000,以及一个正整数S(S<100 000 000)。编写一个程序,求序列中连续元素的子序列的最小长度,其和大于或等于S。


输入


第一行是测试用例的数量。对于每个测试用例,程序必须从第一行读取数字N和S,以间隔隔开。序列号在测试用例的第二行给出,用间隔隔开。输入将在文件结束时完成。


输出


对于每种情况,程序都必须在输出文件的单独一行上打印结果。如果没有答案,请打印0。

#include<iostream>
#include<queue>
using namespace std;
int main(){
	int x,n,s,a;
	int ans;
	int sum;
	cin>>x;
	while(x--){
		queue<int > q;
		ans=100000000;
		sum=0;
		cin>>n>>s;
		while(n--){
			cin>>a;
			sum=sum+a;
			q.push(a);
			while(sum>=s){
				if(q.size()<ans){
					ans=q.size();
				}
				sum=sum-q.front();
				q.pop();	
			}
		}
		if(ans==100000000) cout<<"0"<<endl;
		else cout<<ans<<endl;
	}
	return 0;
} 

  • 2
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值