1109 Group Photo(甲级)刷题

Formation is very important when taking a group photo. Given the rules of forming K rows with N people as the following:

  • The number of people in each row must be N/K (round down to the nearest integer), with all the extra people (if any) standing in the last row;

  • All the people in the rear row must be no shorter than anyone standing in the front rows;

  • In each row, the tallest one stands at the central position (which is defined to be the position (m/2+1), where m is the total number of people in that row, and the division result must be rounded down to the nearest integer);

  • In each row, other people must enter the row in non-increasing order of their heights, alternately taking their positions first to the right and then to the left of the tallest one (For example, given five people with their heights 190, 188, 186, 175, and 170, the final formation would be 175, 188, 190, 186, and 170. Here we assume that you are facing the group so your left-hand side is the right-hand side of the one at the central position.);

  • When there are many people having the same height, they must be ordered in alphabetical (increasing) order of their names, and it is guaranteed that there is no duplication of names.

Now given the information of a group of people, you are supposed to write a program to output their formation.

Input Specification:

Each input file contains one test case. For each test case, the first line contains two positive integers N (≤104), the total number of people, and K (≤10), the total number of rows. Then N lines follow, each gives the name of a person (no more than 8 English letters without space) and his/her height (an integer in [30, 300]).

Output Specification:

For each case, print the formation -- that is, print the names of people in K lines. The names must be separated by exactly one space, but there must be no extra space at the end of each line. Note: since you are facing the group, people in the rear rows must be printed above the people in the front rows.

Sample Input:

10 3
Tom 188
Mike 170
Eva 168
Tim 160
Joe 190
Ann 168
Bob 175
Nick 186
Amy 160
John 159

Sample Output:

Bob Tom Joe Nick
Ann Mike Eva
Tim Amy John

题目大意

就是给n个人的数据,把他们排成k排,每排依次按身高排,最高的在中间,然后依次一左一右排剩下的最高的人。注意当身高一样时按名字字符串大小来排;每排人数大致一致,弱多了人,就平均分给后排。

代码详情

#include<iostream>
#include<algorithm>
using namespace std;
const int maxn = 10005;

struct node {
	int data;
	string s ;
	int shun;//按每排的人数用sort函数来对一个片段重新排序
}x[10005];

bool cmp(node a, node b) {
	if (a.data == b.data)
		return a.s > b.s;
	else
		return a.data < b.data;
}

bool cmp2(node x1, node x2) {
	return x1.shun < x2.shun;
}

void print(int begin, int end, int ca) {
	int y = (begin + end) / 2;
	if ((begin + end) % 2 == 1) {
		y += 1;
	}
	for (int i = begin; i <= end; i++) {
		if ((end - i) % 2 == 0) {
			x[i].shun = end + (end - i) / 2;
		}
		else {
			x[i].shun = end - (end - i) / 2 - 1;
		}
	}
	sort(x + begin, x + end + 1, cmp2);
	for (int i = begin; i < end; i++) {
		cout << x[i].s << " ";
	}
	cout << x[end].s << endl;
	return;
}

int main() {
	int n, sum, a[maxn][maxn] = { 0 };
	cin >> n >> sum;
	for (int i = 0; i < n; i++) {
		cin >> x[i].s >> x[i].data;
	}
	sort(x, x + n, cmp);

	int column = n / sum;//每行至少几人
	int	 yu = n % sum;//多余几人
	int j = column + 1, all = n;//all用来记录起始数组下标和结尾下标,
	//j代表具体每行几人。
	for (int i = 0; i < sum; i++) {
		if (i == yu)
			j = column;
		print(all - j, all - 1, j);
		all -= j;
	}

	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值