PAT (Advanced Level) Practice 1157 Anniversary (STL + 模拟)

题目详情 - 1157 Anniversary (pintia.cn)

Zhejiang University is about to celebrate her 122th anniversary in 2019. To prepare for the celebration, the alumni association (校友会) has gathered the ID's of all her alumni. Now your job is to write a program to count the number of alumni among all the people who come to the celebration.

Input Specification:

Each input file contains one test case. For each case, the first part is about the information of all the alumni. Given in the first line is a positive integer N (≤105). Then N lines follow, each contains an ID number of an alumnus. An ID number is a string of 18 digits or the letter X. It is guaranteed that all the ID's are distinct.

The next part gives the information of all the people who come to the celebration. Again given in the first line is a positive integer M (≤105). Then M lines follow, each contains an ID number of a guest. It is guaranteed that all the ID's are distinct.

Output Specification:

First print in a line the number of alumni among all the people who come to the celebration. Then in the second line, print the ID of the oldest alumnus -- notice that the 7th - 14th digits of the ID gives one's birth date. If no alumnus comes, output the ID of the oldest guest instead. It is guaranteed that such an alumnus or guest is unique.

Sample Input:

5
372928196906118710
610481197806202213
440684198612150417
13072819571002001X
150702193604190912
6
530125197901260019
150702193604190912
220221196701020034
610481197806202213
440684198612150417
370205198709275042

Sample Output:

3
150702193604190912

代码如下:

#include<iostream>
#include<cstring>
#include<algorithm>
#include<set>
#include<vector>
#include<string>

using namespace std;

const int inf = 0x3f3f3f3f;
int n, m;
set<string> s;
vector<string> v;
vector<string> vv;
string res;

int main() {
    ios::sync_with_stdio(false);
    cout.tie(nullptr);

    cin >> n;

    string a;
    for(int i = 0; i < n; i ++) {
        cin >> a;
        s.insert(a);
    }

    cin >> m;

    for(int i = 0; i < m; i ++) {
        cin >> a;
        if(s.count(a)) {
            v.push_back(a);
        }
        vv.push_back(a);
    }

    if(v.size()) {
        cout << v.size() << "\n";
        int minn = inf;
        for(int i = 0; i < v.size(); i ++) {
            int temp = 0;
            for(int j = 6; j <= 13; j ++) {
                temp *= 10;
                temp += v[i][j] - '0';
            }
            if(temp < minn) {
                res = v[i];
                minn = temp;
            }
        }
        cout << res;
    } else {
        cout << 0 << "\n";
         int minn = inf;
        for(int i = 0; i < vv.size(); i ++) {
            int temp = 0;
            for(int j = 6; j <= 13; j ++) {
                temp *= 10;
                temp += vv[i][j] - '0';
            }
            if(temp < minn) {
                res = vv[i];
                minn = temp;
            }
        }
        cout << res;
    }

    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值