最接近数问题

设计算法找出整数数组a[n](n<=50)中相差最小的两个元素(称为最接近数)的差。

输入格式:

第一行为数组大小n,第二行为n个数组元素,元素之间用空格分开

输出格式:

最接近数的差

输入样例:

5

65 38 26 75 40

输出样例:

2

代码位置:

package com.niuke.ALG;

import java.util.Scanner;

//最接近数
public class cloNumber {
 
//找最小数
	public static int minNumber(int temp[]) {
		int min=temp[1]-temp[0];
		for(int i=2;i<temp.length;i++) {
			if(min>temp[i]-temp[i-1]) {
				min=temp[i]-temp[i-1];
			}
		}
		return min;
	}
	
//	冒泡排序法
	public static int[] bubbleSort(int[]temp) {
		for(int i=0;i<temp.length;i++) {
			for(int j=0;j<temp.length-1-i;j++) {
				if(temp[j]>temp[j+1]) {
					int t =temp[j];
					temp[j]=temp[j+1];
					temp[j+1]=t;
				}
			}
		}
		return temp;
		
	}
	
	
	public static void main(String[] args) {
		Scanner scan =new Scanner(System.in);
		int n =scan.nextInt();
		int a[]=new int[n];
		
		for(int i=0;i<a.length;i++) {
			a[i]=scan.nextInt();
		}
		a=bubbleSort(a);
		System.out.println(minNumber(a));
	}
}

 

运行截图位置:

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

平胸瑶女神

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值