食物链:动物王国

总时间限制: 

1000ms

内存限制: 

65536kB

描述

动物王国中有三类动物A,B,C,这三类动物的食物链构成了有趣的环形。A吃B, B吃C,C吃A。
现有N个动物,以1-N编号。每个动物都是A,B,C中的一种,但是我们并不知道它到底是哪一种。
有人用两种说法对这N个动物所构成的食物链关系进行描述:
第一种说法是"1 X Y",表示X和Y是同类。
第二种说法是"2 X Y",表示X吃Y。
此人对N个动物,用上述两种说法,一句接一句地说出K句话,这K句话有的是真的,有的是假的。当一句话满足下列三条之一时,这句话就是假话,否则就是真话。
1) 当前的话与前面的某些真的话冲突,就是假话;
2) 当前的话中X或Y比N大,就是假话;
3) 当前的话表示X吃X,就是假话。
你的任务是根据给定的N(1 <= N <= 50,000)和K句话(0 <= K <= 100,000),输出假话的总数。

输入

第一行是两个整数N和K,以一个空格分隔。
以下K行每行是三个正整数 D,X,Y,两数之间用一个空格隔开,其中D表示说法的种类。
若D=1,则表示X和Y是同类。
若D=2,则表示X吃Y。

输出

只有一个整数,表示假话的数目。

样例输入

100 7
1 101 1 
2 1 2
2 2 3 
2 3 3 
1 1 3 
2 3 1 
1 5 5

样例输出

3

典型带权查并集问题,通过边的不同值代表父子节点之间不同的关系。

用0代表相同,1代表被父结点吃,2代表吃父节点

注意(-2)%3=-2,对负数取模时应该+3

压缩路径有助于加快速度。

实现:有些繁琐,但不想再改了。

#define _CRT_SECURE_NO_WARNINGS
#include <iostream>
using namespace std;

struct group {
	int index;//index 代表父结点
	int weight;//weight 代表与父结点的关系,相同为0,被父结点吃为1,吃父节点为2
	group() {
		index = 0;
		weight = 0;
	}
	group(int a, int b) :index(a), weight(b) {};
};
group *animals;
bool exist(int num) {
	if (animals[num].index)return 1;
	else return 0;
}
group find(int num) {//寻找,在此过程中完成路径压缩
	if (animals[num].index != num) {

		 group tmp=find(animals[num].index);
		 animals[num].index = tmp.index;
		 animals[num].weight = (animals[num].weight + tmp.weight) % 3;
	}
	return animals[num];
}
int main(){
	int N, K; cin >> N >> K;
	animals = new group[N+10];
	int errorNum = 0;
	int op, a, b;
	while (K--) {
		cin >> op >> a >> b;
		//cout << animals[1].weight << " " << animals[2].weight << " " << animals[3].weight << " " << endl;
		if (a > N || b > N) {
			errorNum++;
			continue;
		}
		if (a == b) {
			if(op==2)errorNum++;
			continue;
		}
		if (exist(a)) {
			if (exist(b)) {
				group root_a = find(a), root_b = find(b);
				//cout <<" "<< root_a.index << " "<<root_a.weight<<" " << root_b.index <<" "<<root_b.weight<< endl;
				if (root_a.index == root_b.index) {	//在同一棵树中
					if ((op == 1 && root_a.weight != root_b.weight) 
						|| (op == 2 && (root_a.weight + 1) % 3 != root_b.weight)) {
						errorNum++;
						continue;
					}
				}
				else {//不在一棵树中
					animals[root_b.index].index = root_a.index;
					animals[root_b.index].weight = (root_a.weight - root_b.weight + 3 + (op == 1 ? 0 : 1)) % 3;
					//for (int i = 1; i <= N; i++) cout << animals[i].index << " " << animals[i].weight << endl;
							
				}
			}
			else {
				animals[b].index = a;
				animals[b].weight = op == 1 ? 0 : 1;
			}
		}
		else {
			if (exist(b)) {
				animals[a].index = b;
				animals[a].weight =  op == 1 ? 0 : 2;
			}
			else {
				
				animals[a].index = a;
				animals[b].index = a;
				animals[b].weight = op == 1 ? 0 : 1;
			}
		}

	}
	//for (int i = 1; i <= N; i++) cout << animals[i].index << " " << animals[i].weight << endl;
	cout << errorNum;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值