08-图8 How Long Does It Take (25 分)------C语言

Given the relations of all the activities of a project, you are supposed to find the earliest completion time of the project.

Input Specification:

Each input file contains one test case. Each case starts with a line containing two positive integers N (≤100), the number of activity check points (hence it is assumed that the check points are numbered from 0 to N−1), and M, the number of activities. Then M lines follow, each gives the description of an activity. For the i-th activity, three non-negative numbers are given: S[i]E[i], and L[i], where S[i] is the index of the starting check point, E[i] of the ending check point, and L[i] the lasting time of the activity. The numbers in a line are separated by a space.

Output Specification:

For each test case, if the scheduling is possible, print in a line its earliest completion time; or simply output "Impossible".

Sample Input 1:

9 12
0 1 6
0 2 4
0 3 5
1 4 1
2 4 1
3 5 2
5 4 0
4 6 9
4 7 7
5 7 4
6 8 2
7 8 4

结尾无空行

Sample Output 1:

18

结尾无空行

Sample Input 2:

4 5
0 1 1
0 2 2
2 1 3
1 3 4
3 2 5

Sample Output 2:

Impossible

        这题其实是拓扑排序算法,大部分和Dijkstra算法相似,但是因为要计算最早完成时间的话,必须得考虑每个节点入度的问题,只有当指向某一个结点的所有路径上的权值都计算比较过了,我们才能知道这个接点的最早完成时间,后续也才能计算下一个节点的完成时间。

//08-图8 How Long Does It Take (25 分)
#include<stdio.h>
#define Maxsize 100
#include<queue>
using namespace std;

int N, M, G[Maxsize][Maxsize];

int TopSort(void);
int GetMax(int time[]);

int main()
{
    scanf("%d%d", &N, &M);
    int i=0, j=0;
    for(i=0;i<N;i++){
        for(j=0;j<N;j++){
            G[i][j] = -1;
        }
    }
    for(i=0;i<M;i++){
        int v1, v2, weight;
        scanf("%d%d%d", &v1, &v2, &weight);
        G[v1][v2] = weight;
    }
    int time = TopSort();
    if(time!=-1) printf("%d", time);
    else printf("Impossible");
    
    return 0;

int TopSort(void)
{
    int i=0, j=0, v=0, time[N], Indegree[N], cnt=0, TotalTime;
    queue <int> qu;
    for(i=0;i<N;i++){
        time[i] = 0;
        Indegree[i] = 0;
    }
    for(i=0;i<N;i++){
        for(j=0;j<N;j++){
            if(G[i][j]!=-1) Indegree[j]++;
        }
    }
    for(i=0;i<N;i++){
        if(Indegree[i] == 0) qu.push(i);
    }

    
    while(!qu.empty()){
        int v = qu.front();
        qu.pop();
        cnt++;
        for(i=0;i<N;i++){
            if(G[v][i]!=-1){
                if(time[i]<time[v]+G[v][i]){
                    time[i] = time[v]+G[v][i];
                }
                if(--Indegree[i]==0) qu.push(i);
            }
        }
    }
    TotalTime = GetMax(time);
    if(cnt<N) return -1;
    else return TotalTime;
}

int GetMax(int time[])
{
    int max = 0;
    for(int i=0;i<N;i++){
        if(time[max] < time[i]) max=i;
    }
    return time[max];
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值