08-图8 How Long Does It Take(25 分)

Given the relations of all the activities of a project, you are supposed to find the earliest completion time of the project.

Input Specification:

Each input file contains one test case. Each case starts with a line containing two positive integers N (100), the number of activity check points (hence it is assumed that the check points are numbered from 0 to N1), and M, the number of activities. Then M lines follow, each gives the description of an activity. For the i-th activity, three non-negative numbers are given: S[i], E[i], and L[i], where S[i] is the index of the starting check point, E[i] of the ending check point, and L[i] the lasting time of the activity. The numbers in a line are separated by a space.

Output Specification:

For each test case, if the scheduling is possible, print in a line its earliest completion time; or simply output "Impossible".

Sample Input 1:

9 12
0 1 6
0 2 4
0 3 5
1 4 1
2 4 1
3 5 2
5 4 0
4 6 9
4 7 7
5 7 4
6 8 2
7 8 4

Sample Output 1:

18

Sample Input 2:

4 5
0 1 1
0 2 2
2 1 3
1 3 4
3 2 5

Sample Output 2:

Impossible
#include <iostream>
#include <stdio.h> 
#include <string.h>
#include <queue> 
#define MAX -99
#define INF 9999999
/* run this program using the console pauser or add your own getch, system("pause") or input loop */
using namespace  std;
int n,m,cnt=0,max2=0;;
int map[300][300];
struct node
{
	int num;
	int last;
	int rudu;
	int value;
}nodes[100];
void TopSort()
{
	queue <node> q;
	for(int i=0;i<n;i++)
	{
		if(nodes[i].rudu==0)
		{
			q.push(nodes[i]);
		}
	}
	while(!q.empty())
	{
		node p=q.front();
		q.pop();
		cnt++;
		for(int i=0;i<n;i++)
		{
			if(map[p.num][i]!=INF)
			{
				nodes[i].value=max(nodes[i].value,p.value+map[p.num][i]);
				if(--nodes[i].rudu==0)
				{
					q.push(nodes[i]);
				}
			}
		}
	}
	if(cnt!=n)
	{
		cout<<"Impossible";
		return ;
	}
	for(int i=0;i<n;i++)
	{
		if(max2<nodes[i].value)
		{
			max2=nodes[i].value;
		}
	}
	cout<<max2;
}
void init()
{
	int start,end,last;
	for(int i=0;i<n;i++)
	{
		for(int j=0;j<n;j++)
		{
			map[i][j]=INF;
		}
	}
	for(int i=0;i<n;i++)
	{
		nodes[i].num=i;
		nodes[i].value=0;
	}
	for(int i=1;i<=m;i++)
	{
		cin>>start>>end>>last;
		map[start][end]=last;
		nodes[end].rudu++;
	}
}
int main(int argc, char *argv[]) 
{
	cin>>n>>m;
	init();
	TopSort();
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值