圆形体体积计算器

该博客介绍了一个C++程序,用于计算球体、圆柱体和圆锥体的体积。程序根据用户输入的指令计算相应几何体的体积,并在每次计算前提示输入半径和高度(如适用)。程序使用while(1)循环允许连续计算,直到用户输入非1、2、3的整数退出。注意输出格式和换行对于程序正确运行的重要性。
摘要由CSDN通过智能技术生成

本题要求实现一个常用圆形体体积的计算器。计算公式如下:

球体体积 V=
3
4

πr
3
,其中r是球体半径。
圆柱体体积 V=πr
2
h,其中r是底圆半径,h是高。
圆锥体体积 V=
3
1

πr
2
h,其中r是底圆半径,h是高。
输入格式:
在每次计算之前,要求输出如下界面:

1-Ball
2-Cylinder
3-Cone
other-Exit
Please enter your command:
然后从标准输入读进一个整数指令。

输出格式:
如果读入的指令是1或2或3,则执行相应的体积计算;如果是其他整数,则程序结束运行。

当输入为1时,在计算球体体积之前,打印Please enter the radius:,然后读入球体半径,完成计算;
当输入为2时,在计算圆柱体体积之前,打印Please enter the radius and the height:,然后读入底圆半径和高,完成计算;
当输入为3时,在计算圆锥体体积之前,打印Please enter the radius and the height:,然后读入底圆半径和高,完成计算。
计算结果在一行内输出,保留小数点后两位。

输入样例:
1
2
3
2.4 3
0
结尾无空行
输出样例:
1-Ball
2-Cylinder
3-Cone
other-Exit
Please enter your command:
Please enter the radius:
33.51
1-Ball
2-Cylinder
3-Cone
other-Exit
Please enter your command:
Please enter the radius and the height:
18.10
1-Ball
2-Cylinder
3-Cone
other-Exit
Please enter your command:
结尾无空行

#include<iostream>
#include<math.h>
#define PI 3.1415926535  
using namespace std;
int main()
{
    int n;
    double radius,height;
    while(1)
    {
        cout<<"1-Ball"<<endl<<"2-Cylinder"<<endl<<"3-Cone"<<endl<<"other-Exit"<<endl<<"Please enter your command:"<<endl;
        cin>>n;
    if(n==1)
    {
        cout<<"Please enter the radius:"<<endl;
        cin>>radius;
        printf("%.2lf\n",4*PI*pow(radius,3)/3);
    }
    else if(n==2)
    {
        cout<<"Please enter the radius and the height:"<<endl;
            cin>>radius>>height;
        printf("%.2lf\n",PI*radius*radius*height);
    }
    else if(n==3)
    {
        cout<<"Please enter the radius and the height:"<<endl;
            cin>>radius>>height;
        printf("%.2lf\n",PI*radius*radius*height/3);
    }
    else
    {return 0;}
    }
}

话说,这个题最初的输入把我看蒙了,1,2,3,我以为是运算三次,后来才明白选了1运算后,2是输入的半径,然后又选择了三运算。也就是在一次运算完可以继续重新开始,所以采用一种while(1)的用法。
另一个是输出指令后记得换行,否则就是1分和满分的差距。。。

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值