C++ 提高运行速度

#include<bits/stdc++.h>
using namespace std;
#define endl '\n'    //用endl替换\n

int main(){


ios::sync_with_stdio(false);//
	cin.tie(nullptr);//
	cout.tie(nullptr);//

return 0;
}

关于sync_with_stdio和cin.tie和cout.tieicon-default.png?t=M3K6https://blog.csdn.net/qq_45475271/article/details/107675845

问题 B: Deque

时间限制: 1.000 Sec  内存限制: 128 MB
提交 状态

题目描述

For a dynamic array A={a0,a1,...}of integers, perform a sequence of the following operations:
push(d, x): Add element x at the begining of A, if d=0. Add element x at the end of A, if d=1.
randomAccess(p): Print element ap.
pop(d): Delete the first element of A, if d=0. Delete the last element of A, if d=1.
A is a 0-origin array and it is empty in the initial state.

输入

The input is given in the following format.
q
query1
query2
:
queryq
Each query queryi is given by

0 d x
or

1 p
or

2 d
where the first digits 0, 1 and 2 represent push, randomAccess and pop operations respectively.

randomAccess and pop operations will not be given for an empty array.

输出

For each randomAccess, print ap in a line.

样例输入 Copy

11
0 0 1
0 0 2
0 1 3
1 0
1 1
1 2
2 0
2 1
0 0 4
1 0
1 1

样例输出 Copy

2
1
3
4
1

提示

1≤q≤400,000
0≤p<0≤p< the size of A
−1,000,000,000≤x≤1,000,000,000

#include<bits/stdc++.h>
using namespace std;
#define endl '\n'//

int n;
deque<int >num;

int main(){
	ios::sync_with_stdio(false);//
	cin.tie(nullptr);//
	cout.tie(nullptr);//
	cin>>n;
	for(int i=0;i<n;i++){
		int x;
		cin>>x;
		if(x==0){
			int a,b;
			cin>>a>>b;
			if(a==0) num.push_front(b);
			else num.push_back(b);
		}	
		else if(x==1){
			int a;
			cin>>a;
			if(num.empty()) continue;///
			cout<<num[a]<<endl;//
		}
		else if(x==2){
			int a;
			cin>>a;
			if(num.empty()) continue;
			if(a==0) num.pop_front();
			else num.pop_back();
		}
	}
	
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值