洛谷P1879 Corn Fields G (状压dp)

原题地址

[USACO06NOV]Corn Fields G

题目描述

Farmer John has purchased a lush new rectangular pasture composed of M M M by N ( 1 ≤ M ≤ 12 ; 1 ≤ N ≤ 12 ) N (1 ≤ M ≤ 12; 1 ≤ N ≤ 12) N(1M12;1N12) square parcels. He wants to grow some yummy corn for the cows on a number of squares. Regrettably, some of the squares are infertile and can’t be planted. Canny FJ knows that the cows dislike eating close to each other, so when choosing which squares to plant, he avoids choosing squares that are adjacent; no two chosen squares share an edge. He has not yet made the final choice as to which squares to plant.

Being a very open-minded man, Farmer John wants to consider all possible options for how to choose the squares for planting. He is so open-minded that he considers choosing no squares as a valid option! Please help Farmer John determine the number of ways he can choose the squares to plant.

农场主 J o h n \rm John John 新买了一块长方形的新牧场,这块牧场被划分成 M M M N N N ( 1 ≤ M ≤ 12 ; 1 ≤ N ≤ 12 ) (1 \le M \le 12; 1 \le N \le 12) (1M12;1N12),每一格都是一块正方形的土地。 J o h n \rm John John 打算在牧场上的某几格里种上美味的草,供他的奶牛们享用。

遗憾的是,有些土地相当贫瘠,不能用来种草。并且,奶牛们喜欢独占一块草地的感觉,于是 J o h n \rm John John 不会选择两块相邻的土地,也就是说,没有哪两块草地有公共边。

J o h n \rm John John 想知道,如果不考虑草地的总块数,那么,一共有多少种种植方案可供他选择?(当然,把新牧场完全荒废也是一种方案)

输入格式

第一行:两个整数 M M M N N N,用空格隔开。

2 2 2 到第 M + 1 M+1 M+1 行:每行包含 N N N 个用空格隔开的整数,描述了每块土地的状态。第 i + 1 i+1 i+1 行描述了第 i i i 行的土地,所有整数均为 0 0 0 1 1 1 ,是 1 1 1 的话,表示这块土地足够肥沃, 0 0 0 则表示这块土地不适合种草。

输出格式

一个整数,即牧场分配总方案数除以 100 , 000 , 000 100,000,000 100,000,000 的余数。

样例 #1

样例输入 #1

2 3
1 1 1
0 1 0

样例输出 #1

9
#include <bits/stdc++.h>

using namespace std;

typedef long long ll, i64;

int state[1020], num[1020], cnt, w[14];
int m, n, f[13][1020][160];
const int P = 100000000;
void init() {
    cin >> m >> n;
    for (int i = 1; i <= m; i++) {
        for (int j = 0; j < n; j++) {
            int c;
            cin >> c;
            c ^= 1;
            if (c) w[i] |= (1 << j);
        }
    }
    for (int i = 0; i < (1 << n); i++) {
        if (i & (i << 1)) continue;
        state[++cnt] = i;
        num[cnt] = __builtin_popcount(i);
    }
   // cout << cnt << "\n";

}

void DP() {
    f[0][1][0] = 1;
    for (int i = 1; i <= m; i++) {
        for (int j = 1; j <= cnt; j++) {
            for (int l = 0; l <= 144; l++) {
                if (l >= num[j]) {
                    for (int k = 1; k <= cnt; k++) {
                        if (!(state[j] & state[k]) && !(state[j] & w[i])
                            && !(state[k] & w[i - 1])) {
                            f[i][j][l] += f[i - 1][k][l - num[j]];
                            f[i][j][l] %= P;
                        }
                    }
                }
            }
        }
    }
    int ans = 0;
    for (int i = 1; i <= cnt; i++) {
        for (int j = 0; j <= 144; j++) {
            ans += f[m][i][j];
            ans %= P;
        }
    }
    cout << ans << "\n";
}
signed main() {
    ios::sync_with_stdio(0), cin.tie(0);

    init();
    DP();
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值