洛谷P3092 No Change G (状压dp)

原题链接

[USACO13NOV]No Change G

题目描述

Farmer John is at the market to purchase supplies for his farm. He has in his pocket K coins (1 <= K <= 16), each with value in the range 1…100,000,000. FJ would like to make a sequence of N purchases (1 <= N <= 100,000), where the ith purchase costs c(i) units of money (1 <= c(i) <= 10,000). As he makes this sequence of purchases, he can periodically stop and pay, with a single coin, for all the purchases made since his last payment (of course, the single coin he uses must be large enough to pay for all of these). Unfortunately, the vendors at the market are completely out of change, so whenever FJ uses a coin that is larger than the amount of money he owes, he sadly receives no changes in return!

Please compute the maximum amount of money FJ can end up with after making his N purchases in sequence. Output -1 if it is impossible for FJ to make all of his purchases.

约翰到商场购物,他的钱包里有K(1 <= K <= 16)个硬币,面值的范围是1…100,000,000。

约翰想按顺序买 N个物品(1 <= N <= 100,000),第i个物品需要花费c(i)块钱,(1 <= c(i) <= 10,000)。

在依次进行的购买N个物品的过程中,约翰可以随时停下来付款,每次付款只用一个硬币,支付购买的内容是从上一次支付后开始到现在的这些所有物品(前提是该硬币足以支付这些物品的费用)。不幸的是,商场的收银机坏了,如果约翰支付的硬币面值大于所需的费用,他不会得到任何找零。

请计算出在购买完N个物品后,约翰最多剩下多少钱。如果无法完成购买,输出-1

输入格式

* Line 1: Two integers, K and N.

* Lines 2…1+K: Each line contains the amount of money of one of FJ’s coins.

* Lines 2+K…1+N+K: These N lines contain the costs of FJ’s intended purchases.

输出格式

* Line 1: The maximum amount of money FJ can end up with, or -1 if FJ cannot complete all of his purchases.

样例 #1

样例输入 #1

3 6 
12 
15 
10 
6 
3 
3 
2 
3 
7

样例输出 #1

12

提示

FJ has 3 coins of values 12, 15, and 10. He must make purchases in sequence of value 6, 3, 3, 2, 3, and 7.

FJ spends his 10-unit coin on the first two purchases, then the 15-unit coin on the remaining purchases. This leaves him with the 12-unit coin.

#include <bits/stdc++.h>

using namespace std;

typedef long long ll, i64;

int a[20], b[100005];
i64 pre[100005];
int f[(1 << 20)];
signed main() {
    ios::sync_with_stdio(0), cin.tie(0);

    int k, n;
    cin >> k >> n;
    i64 s = 0;
    for (int i = 0; i < k; i++) {
        cin >> a[i];
        s += a[i];
    }
    for (int i = 1; i <= n; i++) {
        cin >> b[i];
        pre[i] = pre[i - 1] + b[i];
    }
    pre[n + 1] = (i64)1e18;
    f[0] = 0;
    for (int i = 1; i < (1 << k); i++) {
        for (int j = 0; j < k; j++) {
            if (i & (1 << j)) {
                int l = f[i ^ (1 << j)];
                int ol = l;
                int r = n + 1;
                while (l < r) {
                    int mid = (l + r + 1) / 2;
                    if (pre[mid] - pre[ol] <= a[j]) {
                        l = mid;
                    }
                    else {
                        r = mid - 1;
                    }
                }
                f[i] = max(f[i], l);
            }
        }
    }

    i64 ans = -1;

    for (int i = 0; i < (1 << k); i++) {
        if (f[i] == n) {
            i64 res = 0;
            for (int j = 0; j < k; j++) {
                if (i & (1 << j)) {
                    res += a[j];
                }
            }
            ans = max(ans, s - res);
        }
    }
    cout << ans << "\n";
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值