GRE MGRE

这篇博客详细介绍了如何配置网络设备间的连接,包括R2上的HDLC封装,R2-R3和R2-R4之间的PPP封装,R3和R4的PAP/CHAP认证。此外,还构建了R1、R2、R3的MGRE环境,并通过RIP协议实现内网路由。所有步骤都旨在确保网络互连并允许PC间的通信。最后,验证了PC间连通性并进行了总结。
摘要由CSDN通过智能技术生成

一、ensp的拓扑图

 

二、R2为ISP,其上只能配置IP地址,R1-R2之间的HDLC封装

R1

1.R1配置IP地址 

interface g0/0/0

[R1-GigabitEthernet0/0/0]ip address 192.168.1.1 24

2.R1上的HDLC封装

[R1]interface s4/0/0

[R1-Serial4/0/0]link-protocol hdlc

[R1-Serial4/0/0]ip address 12.1.1.1 24

R2

1.R2配置IP地址以及R2的HDLC封装

[isp]interface s4/0/0

[isp-Serial4/0/0]link-protocol hdlc

[isp-Serial4/0/0]ip address 12.1.1.2 24

[isp]interface s4/0/1

[isp-Serial4/0/1]ip address 23.1.1.2 24

[isp]interface s3/0/0

[isp-Serial3/0/0]ip address 24.1.1.2 24

2.R2上进行做环回

[isp]interface LoopBack 0

[isp-LoopBack0]ip address 2.2.2.2 24


 

R3

1.R3的IP地址配置

[R3]interface s4/0/0

[R3-Serial4/0/0]ip address 23.1.1.3 24

[R3]interface g0/0/0

[R3-GigabitEthernet0/0/0]ip address 192.168.2.1 24
 

R4

1.配置R4上的IP地址

[R4]interface s4/0/0

[R4-Serial4/0/0]ip address 24.1.1.4 24

[R4]interface g0/0/0

[R4-GigabitEthernet0/0/0]ip address 192.168.3.1 24

 

三、R2-R3、R2-R4之间进行PPP封装,R3做pap封装, R4做chap认证,同时R2做为主认证方

R2

[isp]aaa

[isp-aaa]local-user huawei password cipher huawei

[isp-aaa]local-user huawei service-type ppp

1.R3做pap封装,

[isp]interface s4/0/1

[isp-Serial4/0/1]ppp authentication-mode pap

2.R4做chap认证

[isp]interface s3/0/0

[isp-Serial3/0/0]ppp authentication-mode chap 

R3

1.R3的pap封装并且进行刷新测试

[R3]interface s4/0/0

[R3-Serial4/0/0]ppp pap local-user huawei password cipher huawei

[R3-Serial4/0/0]shutdown

[R3-Serial4/0/0]undo shutdown 

R4

1.R4进行chap封装并且进行刷新测试

[R4]interface s4/0/0

[R4-Serial4/0/0]ppp chap user huawei

[R4-Serial4/0/0]ppp chap password cipher huawei

[R4-Serial4/0/0]shutdown 

[R4-Serial4/0/0]undo shutdown 

四、R1、R2、R3构建MGRE环境,仅R1IP地址固定

R1

[R1]ip route-static 0.0.0.0 0 12.1.1.2

[R1-acl-basic-2000]rule 1 permit source any

[R1]interface s4/0/0

[R1-Serial4/0/0]nat outbound  2000

[R1]interface Tunnel 0/0/0

[R1-Tunnel0/0/0]ip address 10.1.1.1 24

[R1-Tunnel0/0/0]tunnel-protocol gre p2mp 

[R1-Tunnel0/0/0]source 12.1.1.1

[R1-Tunnel0/0/0]nhrp entry multicast dynamic 

[R1-Tunnel0/0/0]nhrp network-id 100

R3

[R3]ip route-static 0.0.0.0 0 23.1.1.2  

[R3-acl-basic-2000]rule 1 permit source any 

[R3]interface s4/0/0

[R3-Serial4/0/0]nat outbound 2000

[R3]interface Tunnel 0/0/0

[R3-Tunnel0/0/0]ip address 10.1.1.2 24

[R3-Tunnel0/0/0]tunnel-protocol gre p2mp 
[R3-Tunnel0/0/0]source s4/0/0

[R3-Tunnel0/0/0]nhrp entry 10.1.1.1 12.1.1.1 register 

[R3-Tunnel0/0/0]nhrp network-id 100

R4

[R4]ip route-static 0.0.0.0 0 24.1.1.2

[R4]acl 2000

[R4-acl-basic-2000]rule 1 permit source any 

[R4]interface s4/0/0

[R4-Serial4/0/0]nat outbound 2000

[R4]interface Tunnel 0/0/0

[R4-Tunnel0/0/0]ip address 10.1.1.3 24

[R4-Tunnel0/0/0]tunnel-protocol gre p2mp 

[R4-Tunnel0/0/0]source s4/0/0

[R4-Tunnel0/0/0]nhrp entry 10.1.1.1 12.1.1.1 register 

[R4-Tunnel0/0/0]nhrp network-id 100

五、内网使用RIP获取路由,所有PC可以互相访问,并且可访问R2的环回

R1

[R1]rip 1

[R1-rip-1]version 2

[R1-rip-1]network 10.0.0.0

[R1-rip-1]network 192.168.1.0

R3

[R3]rip 1

[R3-rip-1]version 2

[R3-rip-1]network 10.0.0.0

[R3-rip-1]network 192.168.2.0

R4

[R4]rip 1

[R4-rip-1]version 2

[R4-rip-1]network 10.0.0.0

[R4-rip-1]network 192.168.3.0

六、关闭水平分割

[R1]interface  Tunnel 0/0/0

[R1-Tunnel0/0/0]undo rip split-horizon

七、验证pc1到pc2,以及pc2到pc3是否连同

1.pc1到pc2是否连同

 

2.pc2到pc3是否连同

 八、总结

继续加油,冲冲冲

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值