1007 Maximum Subsequence Sum

10 篇文章 0 订阅
9 篇文章 0 订阅

题目描述:

Given a sequence of K integers { N1​, N2​, ..., NK​ }. A continuous subsequence is defined to be { Ni​, Ni+1​, ..., Nj​ } where 1≤i≤j≤K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification:

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (≤10000). The second line contains K numbers, separated by a space.

Output Specification:

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:

10
-10 1 2 3 4 -5 -23 3 7 -21

Sample Output:

10 1 4

 解题思路:

我们可以定义一个数组to_max,to_max[i]表示直到第i个数(包括自己)最大序列和

to_max数组遍历过程赋值:

if (i == 0)
		{
			to_max[i] = arr[i];
		}
		else if (to_max[i - 1] >= 0)
		{
			to_max[i] = to_max[i - 1] + arr[i];
		}
		else
		{
			to_max[i] = arr[i];
		}

所以我们就可以找到之前的最大序列和,并且在遍历过程中比较出(第一个)最大的to_max[i]并且记录下来,再记录下标

因为题目说了要最小的i,j

序列的结尾找到了,找开头就从结尾遍历回去直到to_max[index]<0,那么index+1就是开头

特殊情况:

If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

就是说全部都是负数就输出0 和序列的开头和结尾

特殊情况处理:

if (maxsum < 0)
	{
		cout << "0" << " " << arr[0] << " " << arr[n - 1];
	}

代码如下:

#include <bits/stdc++.h>
using namespace std;

int main()
{
	int n;
	cin >> n;
	int* arr = new int[n];
	int* to_max = new int[n];
	int maxsum = INT_MIN, maxsum_low = 0;

	for (int i = 0; i < n; i++)
	{
		cin >> arr[i];

		if (i == 0)
		{
			to_max[i] = arr[i];
		}
		else if (to_max[i - 1] >= 0)
		{
			to_max[i] = to_max[i - 1] + arr[i];
		}
		else
		{
			to_max[i] = arr[i];
		}

		if (to_max[i] > maxsum)
		{
			maxsum = to_max[i];
			maxsum_low = i;
		}
	}

	int index = 0;

	if (maxsum < 0)
	{
		cout << "0" << " " << arr[0] << " " << arr[n - 1];
	}
	else
	{
		for (index = maxsum_low - 1; index >= 0; index--)
		{
			if (to_max[index] < 0)
			{
				break;
			}
		}

		cout << maxsum << " " << arr[index + 1] << " " << arr[maxsum_low];
	}

	return 0;

}

结果截图:

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值