1013 Battle Over Cities

10 篇文章 0 订阅
9 篇文章 0 订阅

题目描述:

It is vitally important to have all the cities connected by highways in a war. If a city is occupied by the enemy, all the highways from/toward that city are closed. We must know immediately if we need to repair any other highways to keep the rest of the cities connected. Given the map of cities which have all the remaining highways marked, you are supposed to tell the number of highways need to be repaired, quickly.

For example, if we have 3 cities and 2 highways connecting city1​-city2​ and city1​-city3​. Then if city1​ is occupied by the enemy, we must have 1 highway repaired, that is the highway city2​-city3​.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 3 numbers N (<1000), M and K, which are the total number of cities, the number of remaining highways, and the number of cities to be checked, respectively. Then M lines follow, each describes a highway by 2 integers, which are the numbers of the cities the highway connects. The cities are numbered from 1 to N. Finally there is a line containing K numbers, which represent the cities we concern.

Output Specification:

For each of the K cities, output in a line the number of highways need to be repaired if that city is lost.

Sample Input:

3 2 3
1 2
1 3
1 2 3

Sample Output:

1
0
0

 题目大意:给定一张城市地图,要求求出其中的一个城市被占领后要修的最少的道路,使剩余城市之间仍然连通。 

解题思路:

1.我们可以去判断城市被占领后,图有多少个联通子图,把这些连通子图连接起来所需的道路即是题目所求

2.我们可以用dfs深度遍历图的各个节点,建立数组visited来记录被访问的节点,访问过记1.

遍历完一个节点,然后找visited数组中为0的节点(即没访问过的节点,证明不在同一个连通图),继续遍历,直至所有节点都被访问过,过程中我们可以用sum记录连通子图的数量,输出sum-1即可

3.对于被占领的城市,我们可以在遍历的时候跳过即可。

4.记得是无向图,用邻接表构图时要记得两个节点都要插入,不然会漏边。

插入要用头插法,不然会超时


ac代码:

#include <bits/stdc++.h>
using namespace std;

class Vexnode
{
public:
	int node;
	Vexnode* next;

	Vexnode()
	{
		node = 0;
		next = nullptr;
	}
};

class Arcnode
{
public:
	int data;
	Vexnode* firvex;

	Arcnode() :data(0), firvex(nullptr) {}
};

class Graph
{
public:
	int Arcnum;
	int Vexnum;
	int* visited;
	Arcnode* arr;

	Graph(int a, int v)
	{
		this->Arcnum = a;
		this->Vexnum = v;

		arr = new Arcnode[a + 1];
		visited = new int[a + 1];
	}

	void setGraph()
	{
		for (int i = 1; i <= Arcnum; i++)
		{
			arr[i].data = i;
			arr[i].firvex = nullptr;
			visited[i] = 0;
		}

		for (int i = 0; i < Vexnum; i++)
		{
			int base, distination;
			cin >> base >> distination;

			Vexnode* p = new Vexnode ,* q = new Vexnode;
			p->node = distination;
			q->node = base;

			insert(arr, p, base);
			insert(arr, q, distination);
		}
	}

	void insert(Arcnode* t, Vexnode* p, int n)
	{
		if (t[n].firvex == nullptr)
		{
			t[n].firvex = p;
		}
		else
		{
			Vexnode* now = t[n].firvex;

			p->next = now;

			t[n].firvex = p;
		}
	}
};

void DFS(Graph G, int index, int ban)
{
	if (index == ban)
	{
		return;
	}
	else
	{
		G.visited[index] = 1;
	}

	for (Vexnode* p = G.arr[index].firvex; p != nullptr; p = p->next)
	{
		if (G.visited[p->node] == 0 && p->node != ban)
		{
			DFS(G, p->node, ban);
		}
	}
}

int judge(Graph G, int n)
{
	int sum = 0;

	for (int i = 1; i <= G.Arcnum; i++)
	{
		G.visited[i] = 0;
	}

	for (int i = 1; i <= G.Arcnum; i++)
	{
		if (i == n || G.visited[i] == 1)
		{
			continue;
		}
		else
		{
			DFS(G, i, n);
			sum++;
		}
	}

	return sum;
}

int main()
{
	int n, m, k;
	cin >> n >> m >> k;

	Graph G(n, m);
	G.setGraph();

	for (int i = 0; i < k; i++)
	{
		int tmp;
		cin >> tmp;
		cout << judge(G, tmp) - 1 << endl;
	}

	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值