综合复习之静态路由综合实验

以下是本次实验的主要内容,其主要对全部HCIA 的相关内容进行了复习,但是路由部分使用的是静态路由。

 一、IP划分

 首先对内网192.168.1.0/24进行划分,需要划分为6个网段,有一个是骨干,其他是环回接口或与pc端相连的接口。外网分配的是12.1.1.0/24和1.1.1.0/24网段给主干和环回(模拟pc端)。具体划分在实验图中标出,下面进行配置:

R1:

[R1]interface GigabitEthernet 0/0/0
[R1-GigabitEthernet0/0/0]ip address 192.168.1.1 30
[R1-GigabitEthernet0/0/0]interface GigabitEthernet 0/0/1
[R1-GigabitEthernet0/0/1]ip address 192.168.1.5 30
[R1]interface LoopBack 0	
[R1-LoopBack0]ip address 192.168.1.33 28
[R1-LoopBack0]int l1
[R1-LoopBack1]ip address 192.168.1.49 28

R2:

[R2]interface GigabitEthernet 0/0/0
[R2-GigabitEthernet0/0/0]ip address 192.168.1.2 30
[R2-GigabitEthernet0/0/0]interface GigabitEthernet 0/0/1
[R2-GigabitEthernet0/0/1]ip address 192.168.1.9 30
[R2]interface LoopBack 0
[R2-LoopBack0]ip address 192.168.1.65 28
[R2-LoopBack0]interface LoopBack 1
[R2-LoopBack1]ip address 192.168.1.81 28

R3:

[R3]interface GigabitEthernet 0/0/0
[R3-GigabitEthernet0/0/0]ip address 192.168.1.6 30
[R3-GigabitEthernet0/0/0]interface GigabitEthernet 0/0/1
[R3-GigabitEthernet0/0/1]ip address 192.168.1.13 30
[R3-GigabitEthernet0/0/1]interface GigabitEthernet 0/0/2
[R3-GigabitEthernet0/0/2]ip address 192.168.1.97 27

R4:

[R4]interface GigabitEthernet 0/0/0
[R4-GigabitEthernet0/0/0]ip address 192.168.1.10 30
[R4-GigabitEthernet0/0/0]interface GigabitEthernet 0/0/1
[R4-GigabitEthernet0/0/1]ip address 192.168.1.14 30 
[R4-GigabitEthernet0/0/1]interface GigabitEthernet 0/0/2
[R4-GigabitEthernet0/0/2]ip address 192.168.1.17 30
[R4-GigabitEthernet0/0/2]interface GigabitEthernet 1/0/0
[R4-GigabitEthernet1/0/0]ip address 192.168.1.21 30
[R4]interface LoopBack 0	
[R4-LoopBack0]ip address 192.168.1.129 28
[R4-LoopBack0]interface LoopBack 1
[R4-LoopBack1]ip address 192.168.1.145 28

R5:

[R5]interface GigabitEthernet 0/0/0
[R5-GigabitEthernet0/0/0]ip address 192.168.1.18 30 
[R5-GigabitEthernet0/0/0]interface GigabitEthernet 0/0/2
[R5-GigabitEthernet0/0/2]ip address 192.168.1.22 30
[R5-GigabitEthernet0/0/2]interface GigabitEthernet 0/0/1
[R5-GigabitEthernet0/0/1]ip address 12.1.1.1 24
[R5]interface LoopBack 0	
[R5-LoopBack0]ip address 192.168.1.161 28

isp:

[isp]interface GigabitEthernet 0/0/0	
[isp-GigabitEthernet0/0/0]ip address 12.1.1.2 24
[isp]interface LoopBack 0
[isp-LoopBack0]ip address 1.1.1.1 24

以上就是具体接口的手工配置IP的步骤。

二、进行DHCP配置。

然后pc1,pc2进行dhcp自动获取IP地址。

[R3]dhcp enable 
[R3]ip pool 1
[R3-ip-pool-1]network 192.168.1.96 mask 27	
[R3-ip-pool-1]gateway-list 192.168.1.97	
[R3-ip-pool-1]int g0/0/2
[R3-GigabitEthernet0/0/2]dhcp select global 

 
 三、配置静态路由和缺省路由,内网通

通过静态路由和缺省路由实现简单的内网全通,并且设置空接口注意防环:

R1:

[R1]ip route-static 192.168.1.8 30 192.168.1.2
[R1]ip route-static 192.168.1.16 30 192.168.1.2
[R1]ip route-static 192.168.1.12 30 192.168.1.6
[R1]ip route-static 192.168.1.20 30 192.168.1.6
[R1]ip route-static 192.168.1.16 30 192.168.1.6
[R1]ip route-static 192.168.1.20 30 192.168.1.2
[R1]ip route-static 192.168.1.64 27 192.168.1.2
[R1]ip route-static 192.168.1.128 27 192.168.1.2
[R1]ip route-static 192.168.1.160 27 192.168.1.2
[R1]ip route-static 192.168.1.96 27 192.168.1.6
[R1]ip route-static 192.168.1.128 27 192.168.1.6
[R1]ip route-static 192.168.1.160 27 192.168.1.6
[R1]ip route-static 0.0.0.0 0 192.168.1.2
[R1]ip route-static 0.0.0.0 0 192.168.1.6
[R5]ip route-static 192.168.1.32 27 NULL 0

R2:

[R2]ip route-static 192.168.1.16 30 192.168.1.10
[R2]ip route-static 192.168.1.20 30 192.168.1.10
[R2]ip route-static 192.168.1.12 30 192.168.1.10
[R2]ip route-static 192.168.1.96 27 192.168.1.10
[R2]ip route-static 192.168.1.4 30 192.168.1.1
[R2]ip route-static 192.168.1.96 27 192.168.1.1
[R2]ip route-static 192.168.1.32 27 192.168.1.1
[R2]ip route-static 192.168.1.128 27 192.168.1.10
[R2]ip route-static 192.168.1.160 27 192.168.1.10
[R2]ip route-static 0.0.0.0 0 192.168.1.10
[R5]ip route-static 192.168.1.64 27 NULL 0

R3:

[R3]ip route-static 192.168.1.0 30 192.168.1.5
[R3]ip route-static 192.168.1.8 30 192.168.1.14
[R3]ip route-static 192.168.1.16 30 192.168.1.14
[R3]ip route-static 192.168.1.20 30 192.168.1.14
[R3]ip route-static 192.168.1.32 27 192.168.1.5
[R3]ip route-static 192.168.1.64 27 192.168.1.5
[R3]ip route-static 192.168.1.128 27 192.168.1.14
[R3]ip route-static 192.168.1.64 27 192.168.1.14
[R3]ip route-static 192.168.1.160 27 192.168.1.14
[R3]ip route-static 0.0.0.0 0 192.168.1.14
[R5]ip route-static 192.168.1.96 27 NULL 0

R4:

[R4]ip route-static 192.168.1.0 30 192.168.1.9
[R4]ip route-static 192.168.1.4 30 192.168.1.13
[R4]ip route-static 192.168.1.96 27 192.168.1.13
[R4]ip route-static 192.168.1.32 27 192.168.1.13
[R4]ip route-static 192.168.1.64 27 192.168.1.9
[R4]ip route-static 192.168.1.32 27 192.168.1.9
[R4]ip route-static 192.168.1.160 27 192.168.1.18
[R4]ip route-static 192.168.1.160 27 192.168.1.22
[R4]ip route-static 0.0.0.0 0 192.168.1.18
[R4]ip route-static 0.0.0.0 0 192.168.1.22 preference 61
[R5]ip route-static 192.168.1.128 27 NULL 0

R5:在给100M的接口作为下一跳配置,注意设置优先级61,使1000M优先使用

[R5]ip route-static 192.168.1.8 30 192.168.1.17	
[R5]ip route-static 192.168.1.8 30 192.168.1.21 preference 61
[R5]ip route-static 192.168.1.0 30 192.168.1.17
[R5]ip route-static 192.168.1.0 30 192.168.1.21 preference 61
[R5]ip route-static 192.168.1.4 30 192.168.1.17
[R5]ip route-static 192.168.1.4 30 192.168.1.21 preference 61
[R5]ip route-static 192.168.1.12 30 192.168.1.17
[R5]ip route-static 192.168.1.12 30 192.168.1.21 preference 61
[R5]ip route-static 192.168.1.32 27 192.168.1.17
[R5]ip route-static 192.168.1.32 27 192.168.1.21 preference 61
[R5]ip route-static 192.168.1.64 27 192.168.1.17
[R5]ip route-static 192.168.1.64 27 192.168.1.21 preference 61
[R5]ip route-static 192.168.1.96 27 192.168.1.17
[R5]ip route-static 192.168.1.96 27 192.168.1.21 preference 61
[R5]ip route-static 192.168.1.128 27 192.168.1.17
[R5]ip route-static 192.168.1.128 27 192.168.1.21 preference 61
[R5]ip route-static 192.168.1.160 27 NULL 0

现在就做到简单的内网全通了。

四、nat相关设置(telnet,acl)

先将内网转化为一个公网,使内网能够访问到isp的环回:

[R5]acl 2000	
[R5-acl-basic-2000]rule permit source 192.168.1.0 0.0.0.255
[R5-acl-basic-2000]q
[R5]interface GigabitEthernet 0/0/1	
[R5-GigabitEthernet0/0/1]nat outbound 2000
在R5边界配缺省,使其与外网连接
[R5]ip route-static 0.0.0.0 0 12.1.1.2
[R5]ip route-static 12.1.1.0 24 NULL 0

现在内网就能正常与外网访问即R1-R5都能访问R6(isp)的环回。

在R1上设置telnet服务:

[R1]aaa
[R1-aaa]local-user zuo privilege level 15 password cipher 123456
[R1-aaa]local-user zuo service-type telnet
[R1]user-interface vty 0 4
[R1-ui-vty0-4]authentication-mode aaa

然后在R5上设置nat端口映射进行转换,命令访问R5,实际访问R1:

[R5]interface GigabitEthernet 0/0/1
[R5-GigabitEthernet0/0/1]nat server protocol tcp global current-interface 23 ins
ide 192.168.1.1 23

 以上就是该实验的全部内容,终于完成了,如有错误欢迎指正,可能有相关细节问题,后期会修改。

  • 1
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

左水水%

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值