蓝桥刷题——暴力枚举P4956Davor

# [COCI2017-2018#6] Davor

## 题面翻译

在征服南极之后,Davor 开始了一项新的挑战。下一步是在西伯利亚、格林兰、挪威的北极圈远征。他将在 $2018$ 年 $12$ 月 $31$ 日开始出发,在这之前需要一共筹集 $n$ 元钱。他打算在每个星期一筹集 $x$ 元,星期二筹集 $x+k$ 元,……,星期日筹集 $x+6k$ 元,并连续筹集 $52$ 个星期。其中 $x,k$ 为正整数,并且满足 $1 \le x \le 100$。

现在请你帮忙计算 $x,k$ 为多少时,能刚好筹集 $n$ 元。

如果有多个答案,输出 $x$ 尽可能大,$k$ 尽可能小的。注意 $k$ 必须大于 $0$。

## 题目描述

After successfully conquering the South Pole, Davor is preparing for new challenges. Next up is the Arctic expedition to Siberia, Greenland and Norway. He begins his travels on 31 December 2018, and needs to collect ​N kunas (Croatian currency) by then. In order to do this, he has decided to put away ​X (​X ≤ 100) kunas every Monday to his travel fund, ​X + K kunas every Tuesday, ​X + 2* ​K every Wednesday, and so on until Sunday, when he will put away ​X + 6* ​K kunas. This way, he will collect money for 52 weeks, starting with 1 January 2018 (Monday) until 30 December 2018 (Sunday).

If we know the amount of money ​N​, output the values ​X and ​K so that it is possible to collect the ​**exact** money amount in the given timespan. The solution will always exist, and if there are multiple, output the one with the greatest ​X ​ and smallest ​K ​.

## 输入格式

The first line of input contains the integer ​N​ (1456 ≤ ​N​ ≤ 145600), the number from the task.

## 输出格式

The first line of output must contain the value of ​X (​0 < ​X ​≤ 100 ​)​, and the second the value of

K (K ​> 0 ​)​.

## 样例 #1

### 样例输入 #1

```

1456

```

### 样例输出 #1

```

1

1

```

## 样例 #2

### 样例输入 #2

```

6188

```

### 样例输出 #2

```

14

1

```

## 样例 #3

### 样例输入 #3

```

40404

```

### 样例输出 #3

```

99

4

```

##7 * 52 == 364
##(1 + 2 + 3 + 4 + 5 + 6) * 52 == 1092
##sum=364 * x + 1092 * k
n=int(input())

for k in range(1,101):
    for x in range(100,0,-1)://从大到小迭代
        if 364 * x + 1092 * k ==n:
            print(x)
            print(k)
            break
    if 364 * x + 1092 * k ==n:
        break

        


    
            
    

注:简单的暴力枚举,因为x尽可能大,所以从大到小枚举,退出两层循环不太会,只能这么写

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值